All titles were censured?

I just installed my new WD Passport to my mac book pro and seemed to go ok except I am not able to get access to it to set up my backup plan. I tried Time Machine but it wants to completely erase the contents of the WD disk. I dont think I wanted to do that so i aborted it. My Mac Book Pro is using OSX 10.9.5. and the WD Passport is 2T.
The USER manual doesn’t seem to offer any help as it is written primarily for PCs. Page 27 only covers reformatting and restoration. I would appreciate any help anyone can give me.

This was the topic that was censored: WD Passport installed on my Mac Book Pro but cant access it.

New Passport drives come out of the box formatted for Windows unless the box the drive came is says “My Passport for Mac”.
You will need to format the drive on the Mac in order to use it correctly.

Thankyou for your response Tim. As I have indicated it was loaded ok onto my mac and was reformatted and installed onto my mac. i would like to know how to access it and plan my back ups. I tried to use Time Machine but when i select “passport” in the drop down devices menu it wants to erase my WD device. Should I do that or is there another way to access my WD to execute my back ups. Sorry for not making this more clear in my post.

The question would be, how you have it formatted? EXFat and Fat32 work fine for use on Windows and Mac, but Time Machine prefers HFS for backup.

I dont know what the format is. I simply connected the device and followed the instructions for Mac. I did it twice to ensure it installed OK. Would you recommend using Time Machine? What are the implications of using that App. If not how would I find the formats you describe.

Use the link in my first reply. It will help in formatting the drive. If you want things easier, just let Time Machine format it for you. The drive can still be used for other things besides backup but it will not work on Windows without using a 3rd party app to read a Mac formatted drive.

OK thanks
Time Machine gave me a error message: MediaKit reports not enough space on device for requested operation.
Not sure what that means. I will try your suggestion using Disk Utility.

OK everything appears to have worked OK and it automaticly performed the first save. Thanks for your advice.