All data gone on My Book Studio II


#1

I had the My Book Studio II 4TB in RAID 1, connected through FireWire 800 to MacBook Pro working quite well since May. I had on it over 1.3TB of extremely important media and software backups files (RAID 1 setup was to protect this data). Yesterday morning after starting my mac I found that all data is gone from My Book Studio II - the volume name has reverted to the default one, the drive is empty, WD RAID manager reports all healthy with 0% space used. Looks like at the boot time the unit has re-initialized itself (the time stamps on all hidden system files is exactly the same as boot time), wiping out all. How this could happen?

Called tech support and was told that I need to use the data recovery software (or use the data recovery service) to try to get my data back, but they said nothing about fixing the cause of this catastrophic event. When asked about who will pay for data recovery I was told that it would be me - the unit is only 6 months old, still in warranty and obviously it was the WD hardware’s fault, not mine. When complaining I was told to call again on Monday and ask for Level 2 - tried several times today, just to be told each time to call later due to high volume calls to Level 2.

In the meantime tried to recover data myself.

First tried to use the Stellar Phoenix Mac Data Recovery (as the only app able to recover original directory structure and file names), but the app kept quitting during initialization. Disconnected My Book Studio and started Stellar again - initiated with no issues. Connected back My Book Studio and Stellar crashed immediately. Tried same routine few times with no luck. So, I turned to my second app choice, Data Rescue 3.

Data Rescue 3 started working OK, but after about 20 minutes (0.03% into the progress) the WD RAID manager icon turned red and error message popped up telling me that my unit has a problem and to contact tech support for help. About half a minute after I clicked OK in the error message popup all returned to normal and Data Rescue restarted scanning for lost date - about half an hour later the same happened.

  1. How to get my data back? and

  2. Is it the controller problem inside My Book Studio II or something else? 


Firmware upgrade My Book Studio Edition II failed
#2

Same thing happened here right now! Is it Mavericks fault? 


#3

I don’t think it is Mavericks problem as I was testing OS X 10.9 (on separate partition on my mac) since June and had zero problems with peripherials in all beta versions, and finally installed the GM on main system partition a week before the disaster with My Book Studio II happened. So, I was already running 10.9 GM for at least a week without problems with my WD My Book Studio II unit. My mac shuts down automatically every day at 05:30 after performing overnight backups and cloning, then restarts afresh at 05:50. During that week I also have restarted my mac manually numerous times, mainly due to other software being updated to Mavericks. So, if it would be Mavericks fault it would have happened at the first restart, not about 30 restarts later.


#4

Guess what: I just installed mavericks GM so I clearly think it’s got something to do with that. It MUST have…the drive has been rock solid before that. Western digital: HELP


#5

I reckon that the Time Machine software scripting in Mavericks has a bug in it, that causes it to start again and make a brand new Time Machine record.

According to an Apple support statement:  "Time Machine is a backup utility, not an archival utility, it is not intended as offline storage.

In other words if Time Machine fails, you should still have all your original data in it’s proper place. 

You do, don’t you?

I don’t understand why several folk are panicking over this issue!!!


#6

Same thing happened to me after mavericks install !!!

Please HELP !!!


#7

Yep, is seems like a really big problem. Ignore Alcapone, he has not got a clue.


#8

Ok, the drive reset om Mavericks seems to only be happening when the wd drive manager is loaded. I tried without it for some days, and the unit did not reset. Today I tried and re installed wd drive manager and after a cold boot the unit was reset. (all files gone, and drive name reset to default.). So it seems the wd drive manager is not compatible with Mavericks GM:


#9

backfire,

What RAID did you use - 0 or 1?

What configuration Disk Utility was showing without WD Drive Manager installed?

Did you try to use WD Drive Utilities for Mac instead of WD Drive Manager?

I’m waiting for the replacement unit and would like to prepare myself prior to it’s arrival.


#10

I use raid 1. It’s still a raid 1 even with out any WD software, the mac just sees one big disk. I don’t think Drive utilities works with the legacy drives…

I got so tired of this so I just pulled the plug on the wd my book studio II, in fact I’m thinking of taking the drives out of the unit and installing them in an Icy dock raid usb 3 cabinett instead.

http://www.icydock.com/goods.php?id=160


#11

I also got this problem after installing Mavericks yesterday…this morning I almost got some heart faliure…

I Checked the WD with DiskDrill, and all the files are there and recoverable. (tested on a small amount, but no file structure…13 yrs of files in erratic order…oj oj. )

HELP, WD!!

edit: posted on apple forum this morning, still no answer…
https://discussions.apple.com/message/23499357#23499357


#12

Yeah, something strange is going on…I noticed softraid has been updated:

http://www.softraid.com.

Probably because the guy running that company has the know how to see what’s going on behind the scene so to speak.

Something going on with the way Mavericks deals with partitions and stuff. Hope WD and Apple realizes…


#13

Same happened to me with mavericks (also RAID1), I had to reformat the drive.

Everything ‘seems’ to work now, but the problem is I don’t trust the  My Book Studio II anymore.

Also video seems to stutter when playing back from the external Disk.


#14

Same thing happened here right now!! :frowning:

Screen Shot 2013-10-24 at 6.51.37 pm.jpg


#15

Same thing happened to me with a WD My Book Studio Edition II 6TB. After calling WD numerous times they gave up and asked me to ask Apple what Mavericks does to their raid drive and to try recovering my data with a recovery software. 5TB archive gone at the moment, with a partial backup. I’ve never seen anything like this. Very serious and desperate situation.


#16

Cat’s out of the bag:

http://forums.macrumors.com/showthread.php?t=1660392


#17

As soon as I installed OS X 9.0 I received an error message that my WD External drive was not compatible, and since then all backups have failed.

I emailed WD tech support asking if a fix is in the works, but have not yet received a reply.

So, if WD reads this, please reply and let us know if you are going to make your products compatible with OS X 9.0, and when and how will the fix be distributed to users like me?

Thank you.


#18

I don’t claim to be any expert but my guess is that Apple’s (software?) RAID took over and reconfigured the RAID. WD Drive Manager is obviously imcompatible with Mavericks as it appears multiple times in the menu bar everytime the drive is mounted and does not go away without a restart. The  Empty/“MyBook”  state of the drive is stuck no matter where I tried it (OS 10.8 and 10.6 with and without WD software).

I chatted with a higher level Apple tech support and sent him links to these discussions:  https://discussions.apple.com/thread/5475136?start=0&tstart=0 and  https://discussions.apple.com/message/23505869?ac_cid=tw123456#23505869. The end result at the moment was a low level data recovery recommendation which I will try to avoid as long as I can.

I’m holding my breath waiting for a solution from Apple and/or WD where my old volume and data will magically reappear.


#19

Same disaster here. I’m using DataRescue 3 deep scanning the raid 1 now. And it just crashed 10 mins ago. So there’s 66 hours to go.

Any suggestion? I worried about my data a LOT.

I think I cannot trust WD anymore. I just want my data back.

And I’m puzzled that after upgrading to Mavericks (official formal edition) I still got the raid working. All data just vanished this morning.


#20

My drive was killed too. Looked just like ccontreras’ screen shot, with that EFI volume as well. 

RAID 0, My Book Studio II 6 TB, connected via Apple’s Thunderbolt-to-FireWire-800 adapter.

I dared to connect my Thunderbolt My Book a couple of times, and it seems fine. But I have eight other My Book Studio firewire drives that I don’t know what to do with. They all have the latest firmware from WDC, just like the one that got wiped.