Attention WD: all data gone on my book studio II and everything reset!

After installing Mavericks GM my WD my book studio II has lost all data (time machine backup) and was reset to default drive name. This has happened twice now! HELP!! This  is  so serious.

Have you posted in thw Apple forum?

I think you’ll find that you are not alone with problems associated with Mavericks.

As a rule I never upgrade to a new OS untill all the bugs are sorted. The first issues of new operating systems are are usually bug ridden.

If it only happens with WD drives I think it’s something you should look into. I have other external drives behaving like they should. 

It’s got to be a bug new OS, if your drive worked in Apples older OS. The only thing you’ve changed is the OS. Therefore it must be the OS.

You need to inform Apple that their new OS is not recognising your DW drive.

Same thing happened to me with a WD My Book Studio Edition II 6TB. After calling WD numerous times they gave up and asked me to ask Apple what Mavericks does to their raid drive and to try recovering my data with a recovery software. 5TB archive gone at the moment, with a partial backup. I’ve never seen anything like this. Very serious and desperate situation.

I don’t claim to be any expert but my guess is that Apple’s (software?) RAID took over and reconfigured the RAID. WD Drive Manager is obviously imcompatible with Mavericks as it appears multiple times in the menu bar everytime the drive is mounted and does not go away without a restart. The  Empty/“MyBook”  state of the drive is stuck no matter where I tried it (OS 10.8 and 10.6 with and without WD software).

I chatted with a higher level Apple tech support and sent him links to these discussions: and The end result at the moment was a low level data recovery recommendation which I will try to avoid as long as I can.

I’m holding my breath waiting for a solution from Apple and/or WD where my old volume and data will magically reappear.

Im having the problem with myPassport. MyBook with my backup works fine but MyPassport does not show up in finder. I have alot of files on there that i need. If you find out anything let me know. I am currently trying data rescue 3 so hopefully that works.

Jesus WD, look at this thread:

what are you doing??

1 Like

If you have experienced data loss with the following criteria then please open support cases with both Western Digital and Apple support:

  • MacOS Mavericks 10.9
  • WD Drive Manager / Raid Manager software installed
  • data loss after a restart
  • drives initialised to a single MyBook partition with exposed EFI partition
  • loss of all existing partitions and directory structures

If you are an Apple developer then please report an issue with Apple Bug Reporter and reference #15360478.


just have the same problem. Lost ver important data in a MyBook II 2 TB raid 1. I just have a “MyBook” partition with no data showing. Any directions on how to proceed? I unplugged the mybook from my MacBook pro and reconnected it with just one drive to test so I don’t overwrite any data in the second raid disk.

I’ve read somewhere that installing old MacOS might help… should it?

Thanks for any ideas…

I’ve read somewhere that installing old MacOS might help… should it?

Nope, that wont fix a thing.

I didn’t expect anyone to really want to help.
Apple? WD-Support? Haaaa-ha-ha!!
Look for Recovery-Tools and do it yourself!

Same thing happened to me only with Pc… Western Digital is the only brand of hard drive I’ve had fail. Lost everything and they wouldnt even contact me back after several emails. LaCie is a good brand and so is Seagate. I would move on to a better more reliable product.

Hello.  I installed Mavericks on my computer.  About 3 months later I attached my WD Smartware book to retrieve some data and the intall window for the software came up.  I clicked “retrieve a backup” and again the install window came on.  I did not reinstall as I am afraid to lose all my current data (pictures, videos!). I ran a disk utility and it shows that half of my 1TB is used, however I cannot get to the files. :confused:

Plugged in my wd into an Apple laptop and after realizing it would not allow info to download onto it, I unplugged it. After all of 1 or 2 minutes max…it no longer works on my hp…nor can it be read on my tv…my dvd player…etc…How can I fix this without losing all of my data…I have so many films on it…this really is bad!!!

Thank you for any info you might have to help me out.

hi did you get this fixed as wasting countless hours trying to fix mine  !!  let me know if you did would be very helpful