After router configuration for VPN, Remote access is disabled


I recently subscribed to a VPN service so that I can access Netflix. In order to access from my Apple TV, I did some changes to the router settings. I changed the network settings to the following:

Dynamic IP,

L2TP Server IP Address, with VPN user name and password.

reconnect mode was set to: always

The router model is: Dlink DIR-865L

I’ve check on my cloud’s dashboard settings, the ip is set to ‘dynamic’

Now My cloud can only be accessible in my local network. When i try to access via the mobile app while I’m outside, it says the remote access is disabled.

Not sure if there are other people having the same problem, as I’ve searched the knowledge base and forum and don’t see any.

Thanks in advance for any help!

Think WDMyCloud needs to see your ISP ip rather than VPN ip in order to setup the incoming connections route.

Did you only encountered this after starting using the VPN? With VPN disconnected, toggle the cloud access on WD Dashboard to off then on, is remote access ok?

What is your network/port-forwarding status stated on the WD Dashboard settings while your VPN is connected?

While you’re connected to the VPN, ssh to your wdmycloud, run: curl … Did you see your VPN ip or ISP ip? If its VPN ip, then this is the problem. Your wd2go assigned domain is pointing to your VPN ip which resides on the VPN server rather than your nas location. Therefore you need to research more about your router see if it can assign VPN to separate VLAN.

Hi Nazar78,

Thanks for your reply. i think it is caused by the vpn settings on my router.

i saw diferent ip with the VPN on and off. While VPN is on, the connection under cloud access in dashboard says: no internet connection.

After i’ve turned off the vpn, the remote access is working again and says in dashboard: ‘Connected’ and ‘Port forwarding connection established.’

Is there any way for my cloud to use the vpn ip address instead?

No it’s not possbile unless your VPN provider route back the requested ports back to your ISP. I’m not sure if below works…

Based on the online manual I just saw here, take a look at your router’s “ROUTING” config page see if you can see both WAN(ISP) and VPN interface on any of the dropdown menus. If yes, enabled one of them by clicking on the checkbox. Give it a “Name” say “WDMyCloud” and the followings:

Destination IP:


Gateway: YOUR ISP GATEWAY IP (you can find on the internet settings page)

Metric: 1

Interface: WAN(ISP IP)

I’ve tried to key in the net mask, but it says is invalid…

Errr it doesn’t accept /32 CIDR? Maybe that’s for ipv6. Try ?

hmm… both doe not work.

I went to the “routing” as you’ve advised, but the ‘netmask’ says invalid for both sets of numbers… i’ve also tried to do that in ipv6 routing, but to no avail…

Try ?

Ive also tried to no avail.

I’ve tried calling the Dlink technical support, but they were also unable to get my cloud to be accessed from outside of my LAN through team viewer. They said they will call me again tomorrow, I hope they have an answer then…

Will update if there is news! :slight_smile:

Noted, if they call ask them to give a sample of a valid netmask cause I’m not sure about your router. Quote them this ip its wd2go’s.

If they can solve the incoming connections from team viewer, then there’s hope for the cloud.

My problem is solved!!

I spoke to local WD tech support for half an hour and Dlink tech support for about an hour and a half, but there was no solution.

Then I decided to online chat with the VPN provider. He told me that my both My Cloud devices are supposed to ‘know’ where my actual ip is.

He told me to try another vpn server, as it might sometimes be the servers which block the remote access from passing through for some security reason. 

I changed the vpn server and voila! The remote access is working again.

One thing I’m not sure of is whether changing to static ip on the my cloud devices made any difference. The vpn provider told me it’s always static ip for NAS devices that require remote access.

The static IP setup you see on the nas is for your local lan, he’s referring to external wan static ip.