Adding music from a networked share

I’m not sure if this is a Sonos issue or a MyCloudEX2Ultra one. A couple of days ago I updated the operating system from OS3 to OS5. Until then the Sonos was working fine with the networked shares in place. They then ceased working. The update to MyCloudEX2Ultra required reinstalling Plex and Twonky DNLA server on it. Plex continues to work fine, so access to my music is not lost. But it would be so much more convenient to add the folders separately, as I was able to do until recently.

When trying to add music folders from my MyCloudEX2Ultra to my Sonos music library, I get a pop-up error message that incudes a link to Error 900. It suggests the issue is to do with the IRPStackSize. I’ve followed the instructions at https://support.microsoft.com/en-us/help/106167/error-message-not-enough-server-storage-is-available-to-process-this-c and added the necessary entry to the registry with a stack size of 0x12 - gradually increasing it to that from the default value of 0x4. But I still get the same error message. I’ve also enabled SMBv1 on my Windows 10 PC

Has anyone else encountered this issue? And solved it? Grateful for any advice/help

I seem to have sorted out this issue. In MyCloudEX2Ultra Settings > Windows services I’ve enabled: SMB protocol (SMB1, SMB2, SMB3), and LLTD (link layer topology protocol). But more crucially - not to say, bizarrely - putting a space after the share username when adding the share to my Sonos music library does the trick. Without that it denies me access even though adding a space after the username in the MyCloudEX2Ultra user interface denies me access to the interface! Odd!

1 Like

If the share that you are connecting to on the My Cloud Public or Private?

Public

Hello All, I’ve just found this post I’m also having issues with Sonos and MyCloudEX2Ultra since OS 5 update, I’ve tried the above but I can’t seem to access my music folder which is in my private folder it always returns access denied.

I had an issue with Sonos and MyCloud before the update to OS5. I found that turning on “public” against the relevant folder in MyCloud did the trick.

Hi, thanks but that didn’t work so not sure what to do next, possibly subscribe to a music streaming service or buy another NAS.

In case it helps here’s a link to a Word doc summarising all the things I did - https://u.pcloud.link/publink/show?code=XZ227zXZUCckjuLmABHLQvLJzhHC6pb6oTtV

Hi Kelvin, you’re a star fella it worked I followed everything from your guide from windows-10-enable-smb section and it worked!! It just updating the music library as I type, thank you so much :blush::+1:

Cheers Kevin, been scratching my head over this, no reply from other services, didn’t consdier it would be a WD setting.