Acronis True Image WD edition cloning not working

So I am simply trying to clone my old C: drive from an old 320 GB 5400 rpm drive to a new 1TB 7200 rpm drive. Both drives are WD, old one is a green the new one is a black caviar. I tried windows back up. It will not work. I made a boot CD and even have the new and old drives. I selected the drive to use and the back up to copy from and windows says it can’t do it. Some error about the destination drive was included in the exclusion list. Which is bogus because I can select every drive I want to exclude from the format and I am not selecting the destination drive. It has a specific number and I leave that one open for destination. Regardless windows says no. Then I download acronis true image software. I select the clone drive option. I select the source drive and then when I am allowed to select the destination drive all the drives are grayed out. I can’t select any of them and the next button is grayed out. First I thout it was because I didn’t mount or format the drive. So I did. Same problem. The empty drive shows up in the destination list but is grayed out like the rest of the drives as a choice to copy to. I formatted the drive and wrote files to it to test it. It works fine. I then removed the allocation and tried again thinking maybe acronis needs to see the drive unformatted so it can do the format/mount itself and will add it to the list of destination drives that would be selectable. Nothing. I simply want to clone C and swap it out for the old drive so when the computer boots up it has no idea I swapped it out. Just boots up the same with the same software installs, boot routine, etc.

Well the WD Acronis TI is a hybrid product and I don’t know how up to date they keep it. the publish date is June 2010. it could be missiing drivers for something. Did you see this Also a look over the Acronis forum might be helpful. There are a lot of stickies by Grover that are helpful. Look at this post  especially #11 by Grover.Maybe an image would work. When I make my image I always run from the rescue disk. That just loads a temp Linux app to run the backup then there is no problems from things running in background or automatic updates popping up.