Acronis True Image WD Edition Build 33 Installation Fails (Windows 10)

I had Acronis True Image installed. I also had a WD My Cloud, which failed a couple of days after warranty was up. MyBook also failed. I replaced both with new WD products. Already had WD Smartware installed. The new version of MyBook came with WD disk tools, which I began to install. Warned that these new tools wouldn’t work with Acronis. I uninstalled Acronis True Image, installed WD disk tools. Unfortunately I had assumed the WD product would enable me to clone a HDD like Acronis did. No luck. Have had new WD HDDs sitting here for months, waiting for me to replace a power supply in order to have customizable cable connections. So, getting ready to get that done. Uninstalled all WD software except for Smartware. Downloaded a fresh setup file for True Image (build 33). Began True Image installation, got a little over half way across the progress meter and “Installation has failed,” “Fatal error during installation.” No explanation. Ok, so I tried again. Same result, even had the desktop shortcut created and new startup item acknowledged… I closed everything, rebooted, tried again. Same result. I disabled all antivirus and firewall software. Tried again. Same result. I double-checked and terminated all services and processes related to antivirus and firewall. Tried again, installation failed, same M.O. I unplugged MyBook. Tried again. Installation failed. Thank goodness Old Blue (WD Blue 640 Gb HDD) is still hanging in there. Getting up in years though. It’s the only HDD in my PC. What else can I try?

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

Done, thanks.