6TB My Book + WD Media Player? It USED to work

I’ve tried searching other threads, but I never really found a complete answer to my situation. My current setup right now is a 6TB WD My Book connected to a WDTV Live Media Player.

The thing is, it USED to work until several months down the line, then suddenly the media player stopped recognizing the 6TB My Book altogether. I have swapped out using another 6TB My Book and even used a newly bought Media Player, but I got the same thing. I didn’t upgrade the firmware or anything, it just stopped working one day. When I attached the HD to a PC, all the files are intact and working. The media player just doesn’t recognize the drive anymore.

Any leads?

There are times when you need to eject the USB hard drive using the eject button on the remote control, then run chkdsk within Windows in order to allow for the hard drive to be recognized once again by your Media Player.

Yep, I have the same issue

I went out on a limb and reformatted the drive. It works now. I just find it weird how that became a solution though.