5TB will not index

I have 4 WD_BLACK 5TB P10 Game Portable External Hard Drives on my MacMini running the latest OS. The drives all used to be searchable, but for whatever reason I can no longer search the drives. I tried reformating them and that worked for about 24 hours and then it stopped again. I also have a 2tb SSD and 2-3tb HHDs also attached that don’t not have the same problem.
any idea why this is happening. Apple doesn’t understand it either

Hi @rhazelrigg,

Please refer to the KBA article to troubleshoot the issue: Resolve USB Flash and External Drive Not Detected by Windows or macOS Guided Assist

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

it’s not a mounting or detection error.

I’m able to mount the disks, see the files, as well as read and write to the disk.

the issue is I’m unable to search the disk using the MacOS filer search in MacOS 14.5

it’s as if the index is missing. moreover when I reformat the drive searching forks for about 2 days and then stops

mind you it only happens on the 5tb WD Black and G-Drives I have other SSD and HHD drives that all work fine.

Thank you,
Robert Hazelrigg
Lead Creative

The Graphics Guy
126 Whalepond Rd.
West Long Branch, NJ 07764


Creating more business for your business

You are not listening to my problem. THIS IS NOT a connection issue. I can see the drive. I can access the files. I can use 3rd party apps to search the drive. THE ISSUE IS can not use Apple’s spotlight to search the drive. the drive is not indexed.