4TB G Drive sleeps frequently - slow to wake from Sleep


#1

I have a 4TB G Drive with Firewire 800 connected to a mid 2010 iMac i7. Regardless of the System preference setting, the drive quickly goes into sleep mode, but is very slow to wake from sleep. When I click on the drive icon, I have to wait several (sometimes 15) seconds for the drive to respond/open. I currently use this drive for my iTunes library, and if I don’t “wake” the drive before opening iTunes - iTunes will give an error, discard the existing library file & create a new blank/empty library. VERY annoying & time consuming.

Is there any means of changing the sleep settings to speed up access time?


#2

Hello,

The G-Drive’s design is supposed to keep it spinning at all times. There has been a few instances where on FireWire it behaves differently than our design on older Macs. The fix for this was to use a small 3rd party applet that keeps the drive spinning. It is called KeepDriveSpinning and it will solve your issue.


#3

Hi, Duende here to make this issue more complicated! :wink:

In all seriousness, I have the same issue, but with a twist. My 2TB G Drive is connected to a mid-2010 MacBook Pro with via FireWire 800, but I’m running Windows 8.1 in BootCamp. I am a musician specializing in computer-based recording and production. Many of my software instruments are stored on my G Drive, as I have several hundred gigabytes of these. Problem is, my G Drive goes to sleep after about 5 minutes. If my recording software tries to access a file on it while it’s asleep, my recording software crashes, taking my project with it.

I would love to use the applet you described, but it’s an OSX app. Is there a similar reputable and safe program for Windows?

Thanks,

-Duende


#4

Duende,

On Windows it can sometimes be caused by the power settings on the OS. You can try this:

Click on the Battery / Power icon in the taskbar and select More Power options. In the Control Panel windows which opens, select Change Plan settings for your current Power Plan. In the next window, select Change advanced power settings.

In the Power Options box that opens, click the + sign next to the Hard Disk option. Here you will see the required settings under Turn off hard disk after heading. Change the value to 0.

Click on Apply > OK and exit. This setting will prevent your hard disk from entering the Sleep mode.

If that doesn’t work there is a freeware app that works similarly to KeepDriveSpinning called NoSleepHD HERE


#5

@ Duende
Sorry, I’m not familiar with Windows, I can’t suggest any software which might help your situation.
I think Rydia might have something usefull.

TTFN

William Snook
snookppi@zing-net.ca
Home phone: 905 936-4654


#6

System Preferences, Energy Saver, uncheck put hard disks to sleep when possible.


#7

Yes, Charles, I tried that. However, my 4TB G-Tech drive does not follow the command/control.
The drive goes to sleep very quickly if it is not accessed

The suggested remedy “KeepDriveSpinning https://www.macupdate.com/app/mac/31158/keep-drive-spinning” seems to work, & I have the G-technology Assistant App

William Snook
snookppi@zing-net.ca
Home phone: 905 936-4654


#8

Rydia,

Hello again, how can I get the G-Drive to sleep? I don’t like its noise between the TimeMachine backups?

thanks again,

hank


#9

Hank,

The drives are designed to always spin they are not meant to spin down and sleep. They are considered working drives so they are always ready to go.


#10

Rydia,

I see, did i buy the wrong model for Time machine back-ups?

Thanks,

Hank


#11

Not at all, many people use the G-Drive for Time Machine backups.


#12

OK, Thanks again!

Hank


#13

Sorry to keep bothering you, but is there a way to silence the drive. I can hear it all the time now.

thanks again,

hank


#14

Hi Rydia, Since I updated my Mac to Sierra my 2TB G-drive, which I partly use for backup (TimeMachine) and partly for storage, won’t stop spinning anymore. Before the update it stopped after a while. I understand from previous answers from you that the drive is assigned for always spinning, but it keeps spinning even after put the mac in sleepmode, so it never stops. Before the update it stoppedwhen putting the mac in sleepmode. I think that’s not correct. How can I solve this problem Rydia? Thanks in advance.


#15

We have purchased about 8 G-drives in the last 5/6 years

And with the more recent USB drives ours go to sleep too if unused for a (relatively) short amout of time

This does not happen with older firewire G-drive

I notice there are terminal workarounds and little apps like “keep spinning” that can help - but they seem clumsy options

It is good that Rydia says G-Drives are intended to keep spinning - BUT there does seem to be something strange happening - because G-Drives are going to sleep - but my other branded drives are NOT going to sleep

We are on mac and have set hard drives “never to go to sleep”

Thanks in advance

Jonathan


#16

Same issue here. Windows 10 Pro. G-Drive 4TB keeps going to sleep and is very slow to wake making video editing quite interesting. All other external drives work fine on my workstation (I have a number of them), it is just the G-Drive that sleeps.

I have all Power settings set correctly as well as Serial Buss Settings in Device Manager. again ALL other external drives (Segate, WD, Buffalo) work as expected.

I have used third party programs to keep it spinning but as stated before, it is very clunky.

As these drives are not suppose to sleep at all, is there a firmware update or any other answer?


#17

There are no firmware updates for the device unless it is a GEN5 G-Drive which has firmware updates for a FireWire only related issue.


#18

Thanks Rydia! Much appreciate your help :).

This is an issue effecting a number of people across platforms. Is there any solution?

Thank you again!


#19

I have also G raid 16tb drive with thunderbolt 3 connected to USB. The same problem. Sleeps after few minutes and very very slow to wake up…if you are comoany of Wd group then tell your guys to change that. Cheaper Wd my boom duo have setting to adjust sleep mode or you even disable it. I have 2 of those. I purchased G raid as a reliable drive for my media player and the sleeping and slow wake up thing is bad issue.