G-Drive goes always into sleep mode

My 10 TB G-Drive always goes into sleep mode. I’m on a MBP M1 12.3.1 and I have deactivated “if possible activate sleep mode for hard drives”. It drives me nuts having to wait 30 sec whenever (!) I want to do something. Also when not related to the hard drive.
Thanx in advance
Ulli

1 Like

Has anybody an idea where or who I could ask?
Ulli

Hi @ujoss,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Thanks that was a really good idea. Now let’s hope the support has an answer!

Have you found a suitable answer from Support? If yes, please share here.

Well, it seems to be a Mac OS problem. That’s what the Apple support revealed. They said their software engineers are working at it and maybe after two or so updates they might have solved it. I should reckon with half a year or so.
It would probably be a good idea if WD would also ask for a solution.
:unamused:
Ulli

1 Like

Curious if you ever solved the sleep issue. I still have the same problem with M1Max 16" Macbook. 18 Thunderbolt 3 G-Drive Pro goes to sleep every 30 secs or so with all computer settings set for drives not to go to sleep. I’m about to return the drive for another but if it really is an OS issue I guess there’s no point in getting another G-Drive.

No news so far :frowning: Still falling asleep. I have not used it often, transferred my data to other drives. Your conclusion is also mine.
Ulli

Thanks for the reply! I was hoping after this long there might’ve been a solution. I’m thinking maybe not a ton of people are using them as working drives or there would be more urgency about solving it. If I just used it as a big backup it wouldn’t matter so much. Monterey just updated to 12.5.1 and still no mention of this. Frustrating to have an $800 brick on my desk.

so true!

Quick question for those who are having this issue. Did you have your drive plugged in via a dock? I had the same issue on my M2 Macbook Air with my 12TB G-Drive, and when I switched from plugging in through the dock to directly into my M2 Mac, the problem went away. Probably unrelated, but I had also just updated MacOS Ventura from 13.0 to 13.0.1. I’m starting to think not all Thunderbolt docks support MacOS’s ‘Never put hard disks to sleep’ setting.