Wireless Adapter Connection

Hi Guys,

I’m new here and I have a problem connecting my Dlink DWA 125 wireless adapter to my WD TV Live Media player. Tried all the suggestions I can find online but still can’t get it to work. When I plug in the adapter and go to network settings of the media player, no option of wireless comes out. FW of the media player is 1.06.43. I’m thinking it may not be compatible with device firmware? If so, do I need to rollback my firmware? Or maybe I’m doing it wrong? I plug in the adapter but it doesn’t light up.

Also tried to follow rollback steps found here http://wdc3.custhelp.com/app/answers/detail/a_id/5800/~/how-to-roll-back-the-firmware-on-a-wd-tv-live-hd-media-player-or-wd-tv-live but was unsucessful.

Hope someone can help me. Thanks in advance

Two things …

  1. You’re in the Wrong Forum … this forum is for the 2014 Model
    You question belongs in the Legacy Product (Discontinued Forum)
    New Release - WD TV Live Firmware Version 1.06.43 (1/17/13)

  2. Check the Fimware Revision of your Dlink DWA 125
    http://support.wdc.com/KnowledgeBase/answer.aspx?ID=3805#wireless