Windows Server 2012 Essentials upgrade path?

Hi need2leapfrog,

Now that you mention it, I do recall having a similar issue regarding saving directly to the \mount folder as you’ve encounter… I believe it came about because we’re running the console (or the deployment and imaging tools environment) with elevated privledges (administrator) and launching WSIM or other tools in the user credential space.  Eventhough the user may belong in the admin group, it will not be allowed to edit directly.  You can however, launch tools with the elevated privledges (like WSIM) or say like notepad, from the consoles to make direct edits in the \mount directory.

hope that helps… I’ll make a note to put a mention of that in the article.

also, regarding the NIC drivers… like gramps mentioned, they’re already in the base images, but injecting them early on is ok to…  I only mention at the end of article two that you can use them to build a TEAM.

Double check that you’ve setup DHCP to reserve (or pass) the IP address specific to the NIC MAC addresses on the DX4000.  I don’t go into details on this, but if you have a router/firewall setup for automatic DHCP it will get something.  You may have to poke around the router logs to see what address it is getting.

Gramps - thanks for the suggestion regarding using a spare computer w/monitor to observe what is happening.

tswalker - My first attempt used a normal user account (running apps “as admin”) and, when I ran into the “saving” challenges, I started from scratch while using an admin account but still no joy. Also, running WSIM from an admin account did not overcome the challenge. It seems that the owner of the .wim folders/files is “TrustedInstaller” - and even members of the local/domain admin groups have only Read & Execute privileges.

Q: If the Startnet file was not modified, would that result in the symptoms that I obeserve - booting the Sentinel to “recovery/WinPE” mode but no further progress or ability to communicate via TightVNC?

Regarding the IP address, I will check shortly, but my router is definitely set up to assign a reserved IP address to the MAC address of the DX4000 NIC…

Q: Is there any specific port that must be used when pinging the IP address of the DX4000 from TightVNC or will the default port work?

I’ll do some more investigation…

Mystery solved!

It was the DX4000 IP address. I had assigned a reserved address for the DX4000 in my router (192.168.1.9), however, I disconnected the ethernet cable to insert the USB boot drive and, when reassembling the system, I inadvertantly plugged it into the other ethernet port  - so this changed the MAC address and my router handed out a new IP address for this MAC/NIC (192.168.1.99). Once I pinged the correct IP, everything worked as expected!!

Note to self… remember which ethernet port things are plugged into:flushed:

I have now succeeded in building a functional “boot image” WinPE - now on to PART 2 to build the auto-install media!

excellent!  :smiley:

I’m not certain what is happening on your technician computer.  I just know that for me atleast, when launching the console, executing DISM, and the other tools under “run as administrator”, getting prompted from UAC… I am able to edit directly into the resource (\mount) folder.

I was awake stupidly late last night (nerdsomnia), and I believe I need to make a note in part 2 with some details about the disk configuration.  I feel pretty confident that the drive partitioning should be the same for all DX4000 as I would not imagine WD would alter their configuration scripts and change that layout.  But I think it may be good to mention to people to double check that layout to ensure that the partition on your system is “3” for the 60GB “windows” partition.

anyway… glad to know you’ve made progress there!

Agreed - doubtful that WD would change their configuration scripts… consistency works to their advantage. But probably a good idea to advise people to check.

A couple of additional, tangential questions that you may be able to answer.

  1. Can Windows Storage Server 2012 be installed in a similar manner? Since it is based on Server 2012, I would expect the answer to be yes - just use the Storage Server 2012 source files to build the media. It looks like Storage Server and Server offer very similar capabilities, with the notable exception that Storage Server cannot be a domain controller.

  2. Will this procedure work to install on “non-sentinel approved” disks? I was thinking about removing my primary disks (with OS & data intact) and doing the auto-install on a set of four empty WD RE4 GP (black) drives. It would be very nice if we could start with a new set of empty disks and build a RAID, along with creating the base partitions and, subsequently, installing Server 2012 to the new array:smiley:

Thanks!

OK - Successfully used DISM and DISKPART to backup my Windows partition (C:) and my System partition (assigned F:\ for the imaging operation). All went smoothly… with the Windows.wim image being ~9GB and the System.wim image being ~9MB.

Ready to move onto building the auto-installation image:smiley:

Traveling on business over the next week, so I will provide an update when I return.

Thanks again for the detailed step-by-step instructions!

you’re welcome!  I’m glad to know it has been helpful…

I would say that absolutely, you could use storage server this way… it would be just a matter of using that particular variant, ISO and images to build a custom image.  The processes I cover for building the auto unattended installation have been used to manage workstation images like Windows 8 Pro  :smileyvery-happy:

A couple things to note that may be different is of course the storage server ISO, boot and install images, plus you would need to verify the Indexes that you want to work with.  In the standard server install.wim there are 4 indexes, two for standard/core and two for data center / core… so I would imagine there are specific indexes for storage server and/or essentials too.

I honestly do not know if you are able to use drives outside of WD’s white-list.  The core is realitively open, meaning it is a true wintel platform and standard controllers; however, I have not tried this myself…  would make an interesting experiment though.

good luck on your trip!

Regarding Storage Server 2012, I will plan to try this and report back but, as you say, it should be straightforward. Definitely need to verify the correct indexes as Storage Server has few embedded variants.

I will also attempt the alternative drive scenario, simply because there is really no downside in doing so - if it doesn’t work, nothing gets damaged - just reinstall the original system drives and go from there:wink: The reason that I asked is because I share your perspective that this is a true wintel platform with standard controllers, so no obvious reason why it would not work. My suspicion is that the WD “core” software image contains utilities that check for WD drives and abort if non-WD drives are discovered. With a clean Server installation, no such checks would be performed. Alternatively, maybe the BIOS has some embedded “disk checking” code, but that seems extreme. Either way, no harm in trying.

well… i finished the last article/video this evening showing the LCD in action.

I hope you all enjoy it… I provide a link to the PowerShell script near the bottom of the article.

have fun!

http://blugged.wordpress.com/2013/05/18/wd-dx4000-building-windows-server-2012-part-3-the-lcd/

:smileyvery-happy:

Having some difficulties…

I successfully created the WinPE boot disk in PART 1 and saved partition images of my 12TB DX4000.

I diverged from the instructions by trying to install on a new set of disks, so I created a RAID-5 array on a set of four WD2000EARS disks (I used a separate workstation to create the Intel RAID-5 array). All went well and the DX4000 recognized the array as DISK 0 when booted with WinPE.

Next, I used Diskpart to create the various partitions, including copying the LABELS and GUIDs from the original array.

Next, I created the AUTOUNATTEND image and script (following the directions in PART 2).

The DX4000 successfully booted from the “recovery” flash drive and executed the WinPE pass of copying the image to the 60GB boot partition - with the system executing a REBOOT at the end of this phase.

This is where I have problems - when my system reboots, it displays “Initialization OK - Searching…” on the LCD and it appears to hang at this point (presumably in the “specialization” or “oobe” phase). It is unresponsive to pings, etc. I have booted from Diskpart and verified that all partitions/volumes are intact, so everything seems to have been executed properly to this point.

This may be due to the “non-standard” (WDEARS2000) disks being used, but I thought that I would check to see if anyone could provide any debug guidance/suggestions before resorting to using my orignal disks.

Any ideas?

The way i designed the instructions in Part 2 was so that only the 3rd partition was involved… what you will probably need to do is rebuild the “system” (or partition 1) so that the UEFI boot process is handled correctly… this is most likely what is causing to just sit at searching.  It is looking for the boot partition and/or attempting to load it.

make note here: http://technet.microsoft.com/en-us/library/hh825686.aspx

WD did not create a “recovery” partition though on their design… you can if you want, but… it is really most useful for emergency recovery situations and for our use practically useless as we have no keyboard or display to do this with (hence the need for the WinPE/VNC tool).

also, if you did not make an image of system volume to help, you may need to build it.  (i’m trying to find a link as an example).

ok, so I cannot find a direct example yet, but you’ll basically be using something similar to this:

http://technet.microsoft.com/en-us/library/hh824874.aspx

using BCDBOOT to create the structure for UEFI based on the installation (in partition 3 or W: drive may be the case), to the system partition (which MS likes to use S:)… it will build the boot entry and needed files.

hope that helps.

Yep - I came to the same conclusion regarding the EFI partition.

I imaged both the C:\ and EFI partitions from my original system (and still have the original disk set, since I am using a set of WDEARS disks).

I am have been trying to use DISM to restore the orginal EFI partition contents to my new EFI partition (using “Apply-Image” command), however, I am receiving errors indicating that it is a “protected” partition so DISM will not overwrite the EFI partition.

I will try the BCDBOOT suggestion. Sorry for my ignorance:confounded:

it’s ok man, no worries… i’m definitely not a know-it-all either and find myself fumbling around at times too.

not sure what DISM would error like that… maybe it needs to be made visible before you can write to it.

http://support.microsoft.com/kb/300415

Thanks for the helpful links to MS tech docs… very interesting and educational:smiley:

DISM allowed me to assign volume letters to the UEFI partition, but it would not allow me to remove the HIDDEN attribute. Ultimately, I “cleaned” the disk and recreated/formatted the partitions… I am getting really good at using Diskpart! :wink:

Here’s the real update for today - I succeeded in using the BCDBOOT utility to create Server 2012 boot files in the UEFI partition (using a simple <bcdboot c:\windows> command). Unfortunately, the system still hung at the first reboot during the auto-unattended installation… with the same LCD message “Initialization OK, Searching…”

It seems that WD may have used some additional “creativity” in recognizing the disks during the boot operation because I am pretty confident that the UEFI partition has been properly initialized and the S2012 image is being loaded into the C partition during the WinPE phase of the autounattend.xml execution.

I am starting to think that it may require BIOS edits or, possibly, modifying some low-level manufacturing info in the disk drives (eg: model #, S/N, etc) in order to enable booting from alternate disks.

Success!

tswalker’s blog provides detailed step-by-step instructions - so easy, even I can do it:wink:

S2012 is up and running… seems a little more sluggish than the S2008R2, but functional.

Thanks!

how did you get around the bios edits?

when I try and follow  http://msdn.microsoft.com/en-us/library/windows/hardware/gg463140.aspx the device never boots.

I think if we could embed vnc into the servicing and oobe sections of the unattended modes most of us would be fine.

I found this but stilll cant figure out how to get the wd uefi menu to find my os.
http://technet.microsoft.com/en-us/library/dd799232(v=ws.10).aspx

All the acronyms and new naming conventions are confusing to us old guys

isu-skyman,

First, thanks for the MS links - they are always interesting and educational.

Speaking to your concern about “bios edits”, I do not believe that there are any BIOS edits required (either made by WD or required by the end-user). It took me many attempts to finally get the procedure right, but here is what I have learned:

  1. You should start with a functioning DX4000 S2008R2 array… it already contains the proper disk partition structure

     - System:   100MB

     - MSR:       128MB

     - Windows:   60GB

     - Data:          xTB

  1. If you use tswalker’s 1st guide, you will first build a WinPE boot UFD - with the primary purpose of this step is to make sure that you can access the DX4000 remotely via TightVNC and, importantly, use DISM to save backup images of both the System volume and the Windows (Server 2008R2) volume.

  2. Once you have saved backup images of these two critical volumes, then you can use tswalker’s 2nd guide to build an unatteded installation UFD.

  3. Based on my experience, the key to success is to avoid making changes to the original WD System partition. This is exactly what tswalker’s autounattend script does - it leaves the original WD partitions intact and only re-formats the Windows volume (C:) prior to perform a clean install of S2012.

I originally had difficulty because I wiped the entire drive and re-built the disk from ground up using Diskpart… creating and formatting partitions according to the MS guidelines. But, for some reason, this approach did not work – the DX4000 would not boot – so I just used DISM to re-apply the original WD System volume and, magically, the DX4000 began booting normally (so there may be something special about the WD System volume).

Long story short, I cannot explain exactly why other approaches did not work for me - but I can tell you that if you preserve the original WD partitioning scheme and you retain the otriganl WD System partition, things seem to work OK.

No BIOS edits required.

Thats what I did, I cleaned the drive. I will see what is in the efi partition that is being used to setup the hardware.

Lucky for me I have 2 wd dx4000’s  :smileyvery-happy:

Update:

I was able to get the device to boot by booting to a winpe environment with vnc from a usb key in recovery mode.

  


(

select disk 0

clean

convert gpt

create partition efi size=100

format quick fs=fat32 label=“EFISYS”

assign letter=S

create partition msr size=128

create partition primary size=100000

format quick fs=ntfs label=“Windows”

assign letter=C

list volume

Exit

)|diskpart

net use z: \myfileserver\myshare</font>

dism /apply-image /imagefile:z:<font color="#FF00FF">custom\install.wim /index:1 /applydir:C:\

dism /iamge:c:\ /add-driver /driver:z:<font color="#FF00FF">custom\f6flpy-x64

bcdboot C:\Windows /s S:

bcdedit /set {default} bootstatuspolicy ignoreallfailures

bcdedit /set {default} recoveryenabled yes

bcdedit /set {default} recoverysequence {theUUIDthatwascreated}

bcdedit /delete {default} allowedinmemorysettings

bcdedit /delete {default} isolatedcontext

then I copied these files to the s: drive from
lcdtxt.efi

startup.nsh <-- edited to be cool :wink:

uefidate.nsh

 


The purple items are custom to the configuartion

I am guessing that the efi bios has startup.nsh as the default boot item…what do people think?

Missing from tswalkers instructions

For the fan control I had to install the lpc driver. 

I extracted the driver from the sentinel_software_1_5_8_31.zip by typing:

msiexec /a wdlpcsetup.msi /qb /qb targetdir=c:\wdlpcsetup

then in the device manager on the unknown device I updated the driver by having it search
C:\wdlpcsetup\Western Digital\LPC Driver

I also had to install vcredist_x64.exe to to get the command line to work.

To get the gui working for the raid controller I did not install the driver in the sentinel software zip but downloaded the newer version of the  Intel RST driver

I am not sure if I need to install the SMBus driver or any chipset drivers yet. I skipped the intel nic driver for now and use the teaming built into windows. There is also the WD Enclosure provider that I am investigating.

I put a small cmd file in the registry that sets the LCD to show the 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

@echo off
for /f “tokens=1-2 delims=:” %%a in (‘ipconfig^|find “IPv4”’) do set ip=%%b
set ip=%ip:~1%
lcd clear
lcd 0 “%computername%”
lcd 1 “%ip%”

I was wondering if I could put a message in here too.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute 

Now to work with tswalkers powershell scripts :laughing: