Windows can't boot due to My Book USB 3.0 4TB


I am new at this community and I need help since I already spend 3 days trying to solve this problem.

I recently bought a My Book but havening big problems using it. The problem is that when I connect it to the usb 3.0 port windows doesn’t start up (it freezes when reaching the black screen with the collored windows). Funny is that when I get the cable out of the port windows boots corectly. When Windows is booted I can connect the cable again and Windows finds the HDD correctly.

What I have already done:

* Adjust boot sequence

* Flashed the bios

* Upgraded the firmwire of the HDD
* Installed new USB 3.- Driver

* Installed new chipset drivers

* Checked the HDD for errors

Still no solution. Is there anyone who can help?

I am using a ASUS P8P67 Pro

Kind reagrds,

Michael Janssen

The Netherlands

You should check for a firmware update for the USB 3.0 chipset of your motherboard.

Double check the boot order in the BIOS and make sure USB is after system harddrive.


Had the same problem. The base problem is that BIOS does not recognize more than 2TB drives even though Windows can use it okay. So it gets hung up in the boot. I tried moving the boot sequence but that did not work. Apparently, the BIOS still looks for the drive.

I called WD technical support yesterday. The referred me to knowledge base article 1201. It suggests actually disabling the USB boot option. I did this and the computer now will boot with the drive attached. BUT the boot takes longer because with the BIOS USB disabled I have to wait for Windows to recognize my keyboard and mouse before I can enter my password. 

The WD agent agreed with me that the other option is to return the drive and replace it with a smaller one. I am considering doing just that.

I understand that computers that use UEFI instead of BIOS do not have this problem. 

1 Like

Thanks for sharing the information.


Whilie this can be true for older motherboards, this is no problem for modern boards.  The OP has a recent motherboard. I have the same model board (but with a WD 3 TB drive, not 4 TB) and I have no issues whatsoever.

Also, if you read the OP’s message the problem occurs while booting Windows. It is past the BIOS stage then.

In his case I can think of two possibilities:

  • The firmware of the USB 3.0 controller chip is outdated and does not communicate well with the drive. I had to update the firmware for this controller on my motherboard.

  • The filesystem of his drive has an error and must be checked. If windows finds a drive during startup which has it’s filesystem flag set to dirty it will perform a filesystem check on it while booting. With a 4 TB drive this can take a while.

In this case I would boot up machine without drive, then connect it and perform a filesystem scan.

I was having the same problem with My Book Essential 3TB USB 3.0 that I recently purchased from Amazon for $135. If I powered down with the Western Digital external 3TB attached via USB3 cable the laptop would shut down out of Windows 7 Home Premium w/SP1 64bit but after the screen would go black the computer would continue to run.  When I booted up with it connected, again it would go to a black screen and stay there, never getting to the Windows startup screen. Either way it would hang up on a black screen and stay there.

In an attempt to correct this annoying problem I first updated the WD hard drive firmware from V1.016 to V1.019. I then updated the USB 3.0 Controller the the newest version on my Dell Inspiron N7110 laptop.  Neither prevented my laptop from hanging either during power down or boot up. 

I then went into the Phoenix SecureCore Tiano BIOS setup screen and went to the advanced tab and disabled “USB Emulation”. After saving the configuration and rebooting with the 3TB hard drive attached via USB3 cable the laptop booted up correctly into Windows.  The problem with hanging up on shutdown also disappeared.  The Help Screen within BIOS for “USB Emulation” states:

USB Emulation

This field defines how the BIOS, in the absence of a USB-aware operating system, handles USB devices.  USB emulation is always enabled during POST.

Disabled = USB emulation is on until control is passed to the operating system. Note: you cannot boot any type of USB device (floppy, HDD, or memory key) when this field is off.

Enabled = the USB emulation is always on.

The factory default setting is Enabled.