PC will not boot with My Book connected

Just bought a “My Book” about a week ago. EVERYTIME I boot, I get ye old Dell screen. That’s it. Will sit there. This is that screen where you press F12 to get into the BIOS, but when the cord is plugged in, nada. If I pull the cord off and reboot, I sometimes see a “your last few boots have not been successful…error bla bla bla…”

Mind you that once the PC has gone to the Windows screen, plug it in, no problems after that.

I’ve found in the manual, and on the community here (just one article mind you) on this subject. No, the BIOS is not set to boot USB devices…in fact USB device is #5 on that list now (was #2). Also be aware I have had at least one prior “My Book” and a recent Seagate backup drive on this PC and have never had that problem. This is plugged in on the 3.0 USB port. Opinion: Shall I take it back to where I purchased it?

Today I tried different USB3 ports. I tried USB2 port. I removed a failed duplicate WD drive from the inside of my Dell XPS 8500 (D: drive is the original drive to this PC and duplicated to the newer C: that started failing years ago, but died about 6 mo ago - two weeks later the Seagate backup drive died). Removed a FIT BIT USB transponder that is on the USB3. All failed attempts. Surprised none of you have an idea, or simply tell me to return this one and get a new My Book.

This happens with many brands of storage devices connected via USB to various computers. It could be caused by the motherboard bios and the storage device. You may find even switching to another brand the issue persists.

Few things to check/consider/do

  • Are there any motherboard bios updates available?
  • Can you live with USB boot turned off?
  • Can you live with disabling USB Legacy Support in your bios?
  • Is your MyBook’s firmware up to date?

Any one of these might solve the problem.

If none of this works, consider submitting a ticket with WD.

#WDUserRewards

Thanks for answering! I applaud you!
Tried upgrading the Bios, yes there’s another version…Made PC SLOWER.
Turn off usb support/legacy support in BIOS…done, still screwed with a PC that won’t run Intel RST service without my help turning the service on…
My Book up to date? Maybe we should discuss problem #2? Can’t register. Registered for the “my Cloud” that allegedly should have made this product registration easier…yet I’m still stuck with a 1/2 a real drive because I can’t boot up the PC. Can I really find out if my firmware is upgraded without getting registered, which I can’t do?

I finally found a way to put in a ticket with WD, but I had to pull my teeth out to get that. Not very impressed with WD. Had better success with getting help with Seagate TS. Hopefully I don’t have to return this drive for a full refund and go back to Seagate…

You’re welcome. I own a much older My Book - likely before it had the name. I don’t keep it plugged in though, it is more of a backup now to my NAS. I like the NAS because all my devices can connect directly to it and I don’t have to listen to the sound of hard drives since it lives in its own room.

That isn’t good when a newer version of your bios makes your PC run slower… and super odd that Intel RST isn’t working… research how to check that your system’s scheduler?

Not sure you need to register, is this what WD Discovery app is telling you? Need more information as to what you’re encountering error wise…

Great! Hopefully they can help you out. They are after all the experts.