PC Won't start up with MyBook plugged in

I have a 4T MyBook that I have been using for a few weeks. The other day, my PC would not start up. Just showed the “DELL” screen. When I unplugged the MyBook it would start. The BIOS Boot shows the 1st Boot Device as Windows Boot Manager. The Windows Boot in System Configuration shows (C:\Windows): Current OS; Default OS.
With the MyBook plugged in, I cannot get the the BIOS.

Any Ideas?

Hello!

Have you disabled Boot form USB in BIOS to make sure it doesn’t ever boot form USB plugged devices?

Also, you can read this article, it may help you resolve this.

Computer does not boot with My Book connected

DfM

The folks from Western Digital told me to check the BIOS. That didn’t do anything. Then they told me to try re-formatting the drive. That worked. Fortunately, I hadn’t had the drive for long so I didn’t have much on it yet. It is working now.
Thanks for your help.

This has happened to me three times now. I’m not a techie but I have mucked around with all of the many suggested fixes. None of them work and some are dangerous for those of us who do not know what we are doing.

Here is what worked for me all three times with a My Book 1TB, a My Book 4TB and the third a additional My Book 4TB to fix the other one. I’m using a Dell 8300 as my PC.

Plug in your new drive and place all the files that come with it and place them in a folder on your desk top. Reformat the My Book and make sure you tn change it from exfats storage to NTFS.

Youi can then put your files back on to that drive and it should boot just fine.

This is the only fix that has ever worked for me and its much easier then screwing around in the BIOS.

Just my experience. you do what you think is best for you.