Where Are The Files?

Reader’s Digest version:

  1.  After an hour on the phone with support it was determined that my 3tb My Book Live network drive, which contains close to 700 gigs of data, is probably defective or corrupted.   

  2.  I’ve removed the drive from the case, attached it to a universal drive adapter, and with the help of a freeware program called DiskInternals, I can now see the various folders and files that make up the operating system (I presume).  But where are the 700 gigs of files that I loaded?  I’ve looked everywhere and they’re not there.  WD has indicated that this particular disk is formatted for Linux.  The three computers on my home network are running Windows 7 and Vista.  And btw, the drive worked just fine for about three weeks.

  3.  So the question is this.  How do I locate my data, and is it possible to move it onto one of my pc’s with this method?  If the disk were not formatted for Linux it seems it would be a simple matter of dragging the files over to the pc.  

Does anyone have experience retrieving their data from the 3tb MBL using a hard drive adapter.  If so, how did you do it?  Thank you.


1 Like

Myron, many thanks.  I’ve already loaded DiskInternals, but the problem is that I’m unable to locate my files anywhere within the available partitions.  I’ve gone through each folder (hundreds of them), and come up with nothing that looks the 200,000+ jpegs and RAW photo files that I loaded on the drive, for example.  Search by name produces nothing either.  I’m just wondering if the files are stored in a certain location that I’m missing?  Or are they encrypted and hidden?  

Still trying.  I can see all folders and files on the 3tb MBL, but nothing that looks like anything I saved to this drive.  Obviously, I don’t know as much about this stuff as some of you, but this would seem to be a fairly simple question that someone from WD should be able to answer.  I’ve tried emailing them directly and received no reply.  Simply put, what is the name of the folder that stores files that you copy to this drive?  On a Linux system, generally they go into the home folder, right?  Not so here.  Any help will be appreciated.

And just out of curiosity, why is the drive formatted for Linux when I’m guessing that most of the people who buy it will use it with Windows systems?  That’s not a smart **bleep** kind of question either.  I’m just curious.

I’m no expert, but I believe that Linux is generally considered a better, slimmer OS for consumer grade networking hardware. And the file format on the NAS is irrelevant since it’s translated to “network-speak” anyway before it goes out the ethernet port, then the client computer translates it back to whatever format it needs – NTFS, FAT, mac, whatever.

1 Like

The Operating System of the MBL itself is Linux, thus the filesystem itself is one that’s natively supported by Linux, which is EXT4.

A PC connecting to a network-based storage is completely unaware of the format of a remote disk;  it just knows it’s accessing the content via CIFS or AFP or whatever network protocol is chosen.

The folder that contains ALL shared data, as far as the MBL is concerned, is:


1 Like

Thanks guys, for the explanation.  Looks like I may be out of luck.  There is nothing in my DataVolume or Shares folders.  Perhaps the reset erased it?  Dunno?  The good news is that the drive is spinning and it seems healthy, so maybe I’ll just format it and leave it connected as a second drive.  At least the money won’t be completely wasted.  Would like to have my files back though.  Thanks again.

I’m having the exact same problem with the exact same device. Used the same software you used, searched and searched, nothing.

It somehow reminds me of looking for your music on your iphone through windows Explorer. You can’t see it. This leads me to think that the shared data must somehow be encrypted. Does anyone have any tips or tricks on how to solve this?

cyberoutlaw wrote:

Thanks guys, for the explanation.  Looks like I may be out of luck.  There is nothing in my DataVolume or Shares folders.  Perhaps the reset erased it? 

Ahh.  You didn’t mention previously that you’d done a reset.   Which type did you do?

If all you did was poke the RESET button, that shouldn’t have affected any data.

If you did a “Short” RESTORE, then yes, that reformats the disk … and erases all user content.

If you did a “Long” restore, it does the same thing, plus writes over all the data making it irrecoverable.

In the former case, there’s tools out there (someone else will have to recommend, as I’ve never tried any) that MIGHT be able to recover the files.

1 Like

That’s what I was thinking too.  I’m just going to sit the drive aside for a while and let my blood pressure return to normal.  If’ I come across any solutions in my travels, I’ll post them here.

Is restoring triggered by the reset button by any chance?

Tony - I did the four second poke.  But I may have held it slightly longer than four seconds, but certainly not ten or anything that long.  The support person also walked me thorugh a reset where I held it for four seconds while connecting the drive.  Think that might be why I can’t find anything?

Bastian - my original problem was that the green light never stopped flashing and the drive was constantly hot.  I couldn’t access the drive through the dashboard other than to shut it down.  Nothing else on the dashboard worked.  Someone suggested resetting through the hole in the back.  Like a fool, I didn’t bother to move stuff off the drive first, and after the reset the drive was no longer mapped to Windows and could not be discovered.

I don’t know if there’s any relevence in an extended duration of the Reset-Push.  If there is, it’s not documented…

But it does say that “Resetting does not erase your files.”

Exactly.  And I asked about that before trying the reset.  I don’t know.  I’m not ready to give up.  But, I’ve had enough for now, LOL!  Fortunately, I have redundant backups of all the important stuff, so it’s not a wrist slashing moment.  Thanks again.

Well, I would still like to know where my files are on the drive. Anyone?

Bastiaan - if you find them, please let me know!  I’ll do the same.  If they show up, I’ll update you here.