What to try next if amber light still blinks after soft (4 second) and hard (40 second) resets?

I purchased a single-bay (P/N: WDBCTL0040HWT - 00) unit in Oct 2015 and began using it at that time. I haven’t had much difficulty with it aside from an occasional (say, once a year or so) need to restart it. A few days ago I noticed that the drive was not present on the network, looked at the actual unit, and discovered that its amber light was blinking. The last time I actively read content on the drive (from an Apple TV ) and/or wrote to the device via one of Macs (which is connected to the same local network as is the WD My Cloud device), was about a week or two ago. So I pulled out the power cable from its backside, waited a minute, plugged it back in, and saw that, even after waiting some 5 minutes or so to complete a boot cycle, the amber light was still blinking. I then pulled out and put back in all 4 ends of its two (Ethernet and power) cables. Nothing different, even after waiting 15 minutes. Then I unplugged and restarted the router and then the drive, and got the same results.

Just FYI: From time to time I have updated the device’s firmware. My latest note regarding the device’s firmware is from Jan 2017, which indicates that v04.04.05-101 was then running on it, and was considered current.

After reviewing https://support.wdc.com/knowledgebase/answer.aspx?ID=13986, I pulled the unit out of the networking cabinet it’s normally in and brought it to my desk, where I plugged its Ethernet cable into one of my Macs–one that’s running High Sierra, and a machine that I have used to read and write content on this My Cloud device ever since I first purchased it back in 2015. I then tried the soft (minimum 4-second) reset–though I kept the pin in the reset hole for about 10 seconds. Alas, the amber light was still blinking after waiting some 10 minutes for the unit to come back online. I then tried a hard reset (i.e., a minimum 40-second hold combined with a power on cycle)–though I kept the pin in the reset hole for close to a minute. Still the amber light was blinking after waited with fingers crossed for more than a half hour. I’ve tested the Ethernet cable itself and it’s working fine, so that’s not it. Unfortunately, I don’t have a male/male USB 3 cable handy, so I haven’t tried connecting the drive to my Mac using a USB connection.

My understanding is that a blinking amber light signifies that the device cannot connect via Ethernet (or perhaps it means that it can’t connect to an external source regardless of channel, Ethernet or USB). Does this mean that the device’s internal network controller card is hosed? The device is still whirring, and I do not think it experienced any trauma such as being dropped or falling over or being exposed to excessive heat. As would almost anyone, I’d, of course, seriously morn the loss of the data on the drive.

Presuming that the device’s internal drive is not physically damaged, I’m guessing that I can pull the drive out of the WD enclosure, put it into a different enclosure, and be able to read the drive’s contents via the Mac without having to employ any additional intervening software. Does anyone know if that’s the case? And is that the best course of action at this point given what’s happening?

@cwisniewski You may want to look at this link and the User Manual for your generation of My Cloud.

I have that user manual already and reviewed it before posting. There is nothing in it terms of troubleshooting that I’ve not already performed–and described in my initial post. If you have reviewed that document and believe there is important or helpful information in it that I somehow missed, please point me to the appropriate page/section.