Western digital showing in system report but not mounting El Captain

hello

I was wondering if anyone could possibly help, Im tearing my hair out! I recently upgraded to El Captain (wish I never had after all the problems I have encountered!) when I plug my western digital hard drives in I can see they connect in the system report but they don’t seem to mount on the desktop?!

Once I upgraded they mounted for a little while, I then left my computer and on return they had disconnected and now won’t mount.

I have tried a fresh install of El Captain to no avail, I have read many forms but can’t find the answer.

please help

1 Like

I have the exact same problem!

I have two MyBook Thunderbolt Duos connected to my iMac. One is configured as a RAID, the other one is JBOD. Ironically enough the RAID drive mounts with no problems, but the JBOD drive (two HD’s, two volumes) won’t.

Unplugged the cable and plugged it back in several times. The drive then eventually will mount for either some hours or just some seconds and then disconnect without a warning.

Apple’s Disk Utility does see the volumes. I can activate them, but after a few seconds they will automatically unmount again. Moreover, it says “0 KB available” which is not the case since I know that there is 1.34 TB free space left on that volume (see second screenshot taken after activating the volume).


El Capitan is out for quite a while now. By now there should be a solution available!!

Regards from Germany (oh - and Happy New Year regardless…)

Mine are both connected by USB, I can’t see mine in disc utilities but they showing in the system report to be connected, I really need to resolve this as I use them for work! I have tried restarting any times and unplugging and replugging. absolute nightmare!

thanks for your support and happy new year to you too.

I wish I could help you out, but I got stuck myself. Apple Disk Utilities shows some weird information (volumes greyed out that are not physically present). Will try to figure out what this is all about.

Right now I’m doing a backup of the affected volumes (which for some reason works flawlessly out of Apple Disk Utility). Once this is done I’ll reformat the drives with the newest version of WD Drive Utilities and see if this will make any difference.

Will keep you posted.

We’re not alone…

https://discussions.apple.com/thread/7262849?start=0&tstart=0

Not so good news…

Apparently, the latest version of WD Drive Utilities is to blame for all this s…t.

Here’s what I tried and did:

  • Erased WD Drive Utilities Helper in System Preferences --> Start Objects and restarted. To no avail.
  • Uninstalled WD Drive Utilities and rebooted. Didn’t change anything.
  • As a matter of fact, my MyBook Thunderbolt Duos went nuts - mounting and unmounting after a couple seconds in a loop forever.
  • As a last resort I connected all drives to my MBP (still running Yosemite…) and re-formated / re-partitioned them with Apple’s Disk Utility. (Luckily I was able to backup all data before).

The bottom line: It cost me one full day to backup and restore 4 TB of critical data before I could get my system back to work. Thank you very much, Western Digital, for leaving your customers out in the cold!

(BTW - if Customer Service department is listening: I’ve never had an issue like that with my Promise Pegasus R6 since the days of Mavericks!)

Thanks PianoPaul,

I think I am going to have to revert both my two MBP’s back to Yosemite until this problem is resolved as I can not afford to not access my drives as I need them for work.

I don’t think Western Digital are listening to these threads as they would have replied and got the problem sorted. Its so frustrating when you spend precious time trying to figure out problems like this.

Western Digital you have let everyone down and I won’t be buying my next HD from you.

One thing I forgot to ask was did the re-format partition work @PianoPaul?
I had never installed WD drive utilities, I just plugged in and used!

Yes, it worked on the drive that is configured for JBOD.

On the other drive (my TimeMachine volume - configured as RAID 0) it worked out sort of. The volume mounts properly again, but in the Apple Disk Utility pane I still see some weird partitions that shouldn’t be there and can’t be deleted (didn’t see them when I configured that drive on my MacBook running Yosemite). Most likely there is some built-in WD program code screwing everything up.

Anyway - I’ve had my fill of Western Digital. I purchased two expensive Thunderbolt housings and more than a dozen premium 2 TB drives from them. Any takers on their side?

Have you guys uninstalled WD Disk utilities? I had an issues with my new WD MyPassport Pro 8TB yesterday, where during copying, one of my harddrive disconnected while connected to the front USB port of the MyPassport. I resetted the computer and it locked up, not even the apple showed up. So naturally I kept rebooting and nothing. I finally disconnected the Mybook and the system booted fine. After it booted I connected the MyBook and everything was fine, I uninstalled WD Disk Utilities and rebooted, everything booted fine and now works 100%. I blame that stupid WD Disk Utility software, unless I missed something?

El Capitan 10.11.2 on 2013 Mac Pro.