WDTV Live Crashing And Rebooting Since Updating To 1.14.09


Updated last night to 1.14.09.

On reboot I have the following symptoms;

When I switch the box on, I get the splash screen, then you get a black screen, then the splash screen again, then the normal menus.

The box no longer detects my 3tb usb hard drive.

Screen intermittently goes black.

Box can no longer open content from my DS212J Plex server.

I’ve tried resetting to factory default, no effect.

I’ve tried manually rolling back to 1.12.14 via usb key, same issues.

174 views and not one suggestion or reply?

Hi Boomhauruk,

Sorry no answer or advice for you at the moment still waiting for WD to sort out what is wrong with the firmware update, I have similar problems to you in that most of my MKV will now not playback with out crashing and restarting making the WD TV SMP for me unusable. Rolled back to 1.13.xx from the official site but all the old movies that worked under it are now experiencing the same problem so rolling back did not help.

My SMP is now sat in the corner as a paper weight will my Laptop has taken over as my streaming centre, I hope WD will sort this out soon, sounds as if it may be a memory leakage in the latest firmware as all crashes are random not time related or even movie event related.

I have the same problem.