WDTV Gen 1 Killing Drives

Hi Folks.

I’ve got a Gen 1 WDTV, and a WD My passport 1TB drive and a WD 640gig 2.5" drive in a startech enclosure. Normally only the My Passport drive is connected to the WDTV, but the other day when I connected it to my computer it gave me an an error saying the drive was damaged and I could only read files from the drive. I copied everything to the 640 gig drive and kept using it for a few days with the WDTV and the same thing happened. 

Is something in my WDTV cooking these drives??

Any ideas?


Have you trying resetting the WDTV? Which firmware version do you have? 

Sounds to me like the drives aren’t getting sufficient power.

Hey Guys,

I’ve got the latest gen 1 firmware.  1.03 .01

I tried to reformat the 640 gig drive on my computer today, but it failed again with a random error. Its weird because this drive is less than 8 months old and I just got it back from WD.

I tried resetting the WDTV today. I think the 640 gig drive is dead… I can barely get it to mount. 

i agree with earlier post that isse could be power. do you have problem using your HDDs on computers or the problem is only with WDTV? did you try to use power supply with your HDD instead of having WDTV providing all power to the drive?