WDMyCloud Samba Mounting failing on Raspberry Pi Plex Server

Hi, I have been successfully using a Raspberry Pi 3 for quite a while now as a Plex server (running under debian/minibian jessie), with my library of files located on a WDMyCloud network drive (so not using it with the inbuilt Twonky DLNA which was always a pain). Each network folder for videos, music and photos are mounted on the Pi using Samba 4.3.11 in the fstab script. This has been working fine for many months until the last week when WDMyCloud was updated to the latest firmware (v04.05.00-315). Since then the library stopped updating and I cannot play any files. e.g. On the Plex web player on Windows, Samsung TV and android phone, it says ‘Please check that the file exists and the necessary file is mounted’.

So I have been investigating on the Pi and found that the mounts are now failing to connect to the network share folders. The folder structure is:-


  • Shared Videos
  • Shared Music
  • Shared Photos

In the fstab file, I have:-

//\040music /mnt/music cifs username=pi,password=xxxx,uid=1000,gid=1000 0 0
//\040videos /mnt/video cifs username=pi,password=xxxx,uid=1000,gid=1000 0 0
//\040pictures /mnt/photos cifs username=pi,password=xxxx,uid=1000,gid=1000 0 0

These three mounts all previously successfully connected. Now when it tries to mount (and also testing so manually from the command sudo mount -a), I get the error:-

mount error(2): No such file or directory

If I start smbclient (running as user ‘pi’) and then try to view one of those folders (e.g. smbclient // music), I get:-

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.3.11]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

However, smbclient will allow me to connect manually to the parent folder (// and then from there I can navigate through to the subfolders fine and can see all the files. So the permissions seem ok for the user (and they haven’t changed from when it was working ok). Also the WDMyCloud as I understand doesn’t support different permissions at subfolder level anyway, so if you have parent folder permission, you can access all the subfolders. I even tried creating a new user on WDMyCloud and trying to mount the folders with the new user, but still get the same error. If I try mounting to just the Public folder, it does work though, so it’s just the subfolders that appear not to be visible or have the right permissions.

Does anyone else have a similar set up for running Plex and have had the same issue recently or have encountered a similar issue and resolved it? Is it an issue with the latest firmware release as it seems a coincidence it’s just started happening since the update?

Many thanks.

1 Like

Hopefully an experienced User will be able to assist since there are no official documents or articles on WD’s database related to the issue at hand.

Did you reset the MyCloud after the upgrade? That often fixes post-upgrade weirdness.

The new firmware changed the default version of SMB that is running; see the f/w release notes; that may have a bearing on your connection.

I don’t like spaces in filenames on unix file systems… They cause problems. I know yours has been working for some time, but… You can put media where you like; you do not have to put it in the default Public/Shared Media folders.

1 Like

Hi, Thanks for the reply. I did do a couple of reboots of MyCloud. After much persistence, I finally worked out what it was. The public folder and subfolders had changed to proper case (i.e. Public and Shared Videos etc) and given linux is case sensitive, it couldn’t find the folders to mount, so just a quick change to the script fixed the issue. Not sure if the MyCloud firmware upgrade had updated the folder names, but at least it’s fixed now.

Those folders have always had Upper Case names.

My guess would be that the new version of Samba is being more strict with the folder names; whereas before, it would ignore case, it’s now enforcing it.