"WDMyCloud is Missing" in WD Sync -- Won't Synchronize

@Jeff_Hart Thank you for your posts, I wish I had read this before buying a My Cloud device. I now want to add my case to the long list of dissatisfied clients. I bought a My Cloud EX2 Ultra a few weeks ago thinking it could replace our Dropbox service for our small office, acting as a “remote” cloud (as advertised).

But as it turns out, after setting up the device for about 20 users I now get a clearer picture of what the problem is, and having wasted a lot of time in the process, it is obvious that WD Sync for Windows simply doesn’t work for remote syncing.

WD Sync for Windows (current version 1.2, but I’ve also tried some previous versions) can’t detect the My Cloud device remotely when logged in your MyCloud.com account.

It works on the local network, and if you first sync/set-up from your local network and then move away and try to connect remotely over the internet it will start giving you messages saying it’s unable to connect or missing.

If you then remove the device (from WD Sync settings) and try to add it remotely, or if you try to first set it up remotely it will simply say that no storage devices were found, even though you are already logged in your MyCloud.com account.

The same thing happens for all our computers running Windows (tested on Windows 7,8.1,10) but we don’t have any problems with our Macs, just like there’s no problem accessing the device from an internet browser or phone app. Only WD Sync on Windows is unable to connect!

I have of course contacted WD support, to get in return that the issue must be with the computer settings, which I would gladly believe if it was not happening to every single computer we have, running Windows.

So if moderators are reading this, I would simply like to ask when should we expect a working version of WD Sync for Windows? The version 2 for Mac is working fine as far as I can tell, why is it taking so long to bring it to Windows?

Can someone prove to me that remote syncing is working on Windows (which is the main reason for our purchase)? or should I just bring back the device for a refund?

Thanks

1 Like

WD Sync DOES work remotely when the My Cloud is properly configured and working for remote access. There are instances where WD Sync isn’t possible from remote locations due to firewall rules at both ends, ISP blocking certain ports, or improperly configured remote access on the My Cloud. The main problem with WD Sync is the lack of options to control various aspects of the program or syncing process.

Many here have chosen to use 3rd party solutions like Free File Sync (http://www.freefilesync.org/) to sync their computer to the My Cloud. The major downside to using any non WD software for remote access, is that configuring remote access becomes more complicated.

Because you bought a My Cloud EX2 Ultra you may want to post to the dedicated EX2 subforum where people more knowledgeable may be able to answer questions or help with specific EX2 Ultra.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2

I am hoping that WD embraces a native app for owncloud which seems to have a more mature syncing client.

This is not the problem and WD is not doing anything to address the issue.

I have even added WD Sync to the Windows 10 firewall rules. The WD Cloud device is visible in my network places and I can browse to it without issue.

The only problem is with WD Sync.

Bullock mate. I followed the setup as written on the WD site and WD Sync does not work. The device can be browsed to and accessed from the My Cloud app.

If this is a configuration issue then please write a post describing the steps for proper configuration.

What setup did you follow that was written by WD? What is your OS? Are you setting up WD Sync initially while connected to the local network or while in a remote location?

I have no problems syncing to a remote My Cloud (single bay) using the WD Sync software. It appears those with Mac’s (especially those with El Capitan) are having trouble with the WD Sync software.

If the My Cloud you want to sync to is not on your local network then, during the WD Sync software installation you can select “Sign in” that one see’s on the following setup screen. And sign in using your MyCloud.com web portal account login.

If the WD Sync software is already installed then one can change the My Cloud they are syncing too by right clicking on the WD Sync icon on the Windows taskbar, then select “Settings”. From the “Folders” screen you can select “Add Device…” which will bring up a similar screen as to the one shown above. From there select “Sign in” and all My Cloud’s associated with your MyCloud.com web portal account should be shown. Here is an example from my end; The My Cloud listed on the left is on my local network, the My Cloud on the right (denoted by the red arrow) is a family member’s My Cloud 200 miles away.

Using the WD My Cloud Desktop program to access that remote My Cloud, here is the proof that I was able to sync several files from the My Cloud sync folder on my local computer to that remote My Cloud.

If the remote My Cloud doesn’t show up or is not listed then its possible there is a problem with the remote access settings on that My Cloud. Its important to ensure the that in the Dashboard > Settings > General > Cloud Access section the “Connection Status” indicates just “Connected” and not “Connected (Relay connection established)”. If it indicates “Connected (Relay connection established)” then one may have to access their router and enable port forwarding to forward (if the configuration for “Remote Access” is to “Default”) the default remote access ports of 80 and 443 to the My Cloud’s IP address.

Hi there, those are great instructions that I followed to the letter when I set up. Everything worked just fine. Then I went on a trip and found myself 1000 miles away from home. Now I am getting the My Cloud missing error. Unfortunately, I cannot remove and reboot because I am not home. I need files that are on my computer and I cannot retrieve them. Either there is an issue with the software that needs to be resolved or there is a piece missing from those instructions. No matter the case, this device is worthless if it cannot be used as a remote syncing device. My whole purpose for purchasing this was for off-site backup. That is not possible if I have to do resets and reboots all the time to keep the WD Sync working.

Hi all. I am posting to this thread in hopes that someone from WD’s Tier 2 support will contact me. After I left my last message, I was contacted by Tier 2 support. After playing a little phone tag, I finally got a representative who accessed my computer and got my WD Cloud working once again. However, in the proecess of doing that, something was changed and I have not been able to connect my WD Lives to any of my Windows Shares. The six computers on my network are no longer showing. For a couple of days I could only see my WD Cloud visable, not when I try to look at my Windows shares it just actc as if it’s loading and never does. All computers have been reset and so has my router. Please assist.

Good news, at long last. WD released a new version of WD sync last week, and things seem to be working properly. I’m not entirely convinced that it will keep working properly (thanks to WD’s abysmal track record), but so far, so good.

If I start encountering errors again, I’ll update the thread. But for now, I would recommend updating to the latest version of the software.

the biggest piece of junk i have ever purchased - initializing for more than a day

2 Likes

I used WD Sync on my school (work - I am teacher) laptop for most of this school year and it worked great and I loved the functionality! At the beginning of June, I started to have the same problem you describe. I also could not access MyCloud.com - it just came to a blank page. I believe something changed on the school network, and did not have time to talk to the IT guy to get it working.

If I used my phone’s mobile hotspot feature and connect that way, it worked fine – on the same computer in the same location. So, that’s how I know it was a problem with the school network. My assumption is some ports were blocked.

Did you try checking your firewall settings on your ISP modem / router?

any solution?

I did call WD on this issue and unfortunately the only fix was rebooting the MyCloud when I got home. That makes it impossible for me to use the MyCloud as an off-site backup as I intended to do. Good luck. If you find a different solution, please come back and share it with me.

​​
its ridiculous …
can you get a redound?

refund?

At this point probably not. I purchased a small one as a trial. Just glad I did not buy the big ones I really wanted.

I am experiencing this same issue now- EX2 running My Sync on windows 10. I am in the process of syncing my entire set of client files (Approx 1M files) and it made it about 1/3 way through before the problems started. Then it slowed to a crawl and eventually I started seeing that ‘cloud is missing’ message. rebooting the cloud and computer eventually brings it back up but then it happens again pretty quickly. I slogged through the remaining files but now when i try to sync any significant number (5k+) files it happens again. I am scared that when I am remotely accessing this thing and really need it, it will fail. That pretty much makes this thing worthless other than to be a troublesome local backup, and hardly a cloud storage device.
I have the latest My Sync software and have tried various suggestions, configs, killing anti virus, etc- nothing seems to work.
Does anyone know if WD is actively working this issue now or should I just look for a different brand and start over?

You could always use a third party sync program for local syncing to the My Cloud. Free File Sync (http://www.freefilesync.org/) is one such third party sync program that is used by some on this subforum.

1 Like

WDMyCloud is missing
I have been struggling with this for quite a long period of time now.
Problem is that after installation of WD sync it all works perfect but after some time the function is degraded. It takes longer and longer time for WD sync to login to remote server and finally the message “WDMyCloud is missing” appears. It takes from one week to several month before the problem occurs. After un-install/re-install WD-Sync I got a new period were it will work.

I have four WD-Mycloud at four differnet locations and doing backup from PC’s on those locations and also from other locations.
What I have found is that the most stable configuration is NOT to use port forward, rather ensure that Relay connection is used. To ensure this UPNP have to be disabled in your router.
Would like to hear this communities experience of this and also if WD have any comments.
Regards

So I bought the MyCloud device for WD Sync pretty much. Now I’m reading the forums. and find no answers at the bottom of these threads. I have the same problem. The MyCloud can’t be found (when connecting remotely.) I can however connect via the web browser and the mobile app with the same username and password.

Has anything come of this?