Wdmcserverd and wdphotodbmergerd disable?

Is this the proper response to the disable command? I was surprised by the “Adding system startup” part at the end. I got a similar response to disabling the wdphotodbmergerd …
(I’m running 04.04.01-112)

NAS:~# update-rc.d wdmcserverd disable
update-rc.d: warning:  start runlevel arguments (none) do not match wdmcserverd Default-Start values (2 3 4 5)
update-rc.d: warning:  stop runlevel arguments (none) do not match wdmcserverd Default-Stop values (0 1 6)
 Disabling system startup links for /etc/init.d/wdmcserverd ...
 Removing any system startup links for /etc/init.d/wdmcserverd ...
 Adding system startup for /etc/init.d/wdmcserverd ...
   /etc/rc0.d/K85wdmcserverd -> ../init.d/wdmcserverd
   /etc/rc6.d/K85wdmcserverd -> ../init.d/wdmcserverd
   /etc/rc2.d/K15wdmcserverd -> ../init.d/wdmcserverd
   /etc/rc3.d/K85wdmcserverd -> ../init.d/wdmcserverd
   /etc/rc4.d/K85wdmcserverd -> ../init.d/wdmcserverd

Hopefully an experienced User will be able to assist.

To stop wdmcserverd and wdphotodbmergerd the following commands should work. Note that when one reboots the My Cloud both services will start up again.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

The following thread discusses how to permanently disable those two services.


Still no comments on the response to the disable command? Please see my original post…

Your using the command “update-rc.d wdmcserverd disable”. If so the system response you received appears to be normal. Its the same output that I receive when running that command.

Conversely if one runs: /etc/init.d/wdmcserverd stop
They should get: [ ok ] Stopping wdmcserver: wdmcserver.

Edit to add: Further the following thread show the same system response as being normal.


You should know if update-rc.d worked or not by issuing the following command

/etc/init.d/wdmcserverd status

which should come back with
[FAIL] wdmcserver is not running. … failed!

The messages that you are getting is probably ok since we are not using any other run levels other than 2 as a default on the cloud anyways. (edited)

When you boot up, you should be on run level 2 (edited) at which both wdcmserverd and wdphotodbmergerd should be disabled.

Ever since last year, I stopped using the update-rc.d command because of firmware update 3.04 which locked me (ssh wise) out of my cloud. There are a bunch of flags that the system creates of which other processes waits until the flags are deleted; thus sometimes deadlocks occurs.

The lock out in fw 3.04 was NOT due to the “update-rc.d wdphotoserverd disable” command.

However, till today, I do not modify my system permanently for the fear that it may cause a firmware update problem.

Thus I only use
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

every time I reboot my cloud.

I don’t know if this command might work but you can give it a try
update-rc.d wdmcserverd disable 0 1 2 3 4 5 6
update-rc.d wdphotodbmergerd disable 0 1 2 3 4 5 6

now there is an interesting untested command of which anyone that wishes to try it might give it a shot. You can set the run priorities using the update-rc.d commands

update-rc.d wdmcserverd start 20 2
update-rc.d wdphotodbmergerd start 20 2

should set the run priorities to 20 on run level 2.

Let me know if you this works. If it doesn’t, call WD Tech support and they will RMA your Cloud :stuck_out_tongue:

That command worked perfectly, and did respond “… not running … failed!”

This has been holding through reboots.

Thank you Ralphael!

do a who -r on your My Cloud. You will see that it is running at runlevel 2. If I remember correctly
runlevel 1 is like safe mode in windows.

Also you don’t have to ssh into the My Cloud every time it reboots to run those commands. Just put your commands in the /etc/rc2.d/S98user-start. It get run every time the My Cloud boots. It does not get changed on a firmware upgrade.


ack!.. I sit corrected (not at a standing desk)… yes rac8006 is correct that it is at run level 2 and run level 1 is single user mode much like safe mode in windows.

… now RAC, in regards to that startup folder that you keep selling me, my reason for not disabling the scans on reboot is that I do want a fairly pristine cloud when I reboot.

If I do add it to the startup and I forget when updating my firmware, my fears are that they will add a clear flag on the scans one day and thus no ssh’ing into the device until the flags are cleared, you will be locked out of the cloud because the scans and other services are stopped permanently.

This was true of fw 3.04 where a flag was permanently set preventing SSH’ing into the device.

If they are going to stop SSH it would be done in one of the scripts that is run before the S98user-start script.
When you use the updaterc.d you cause these script not to run. But using the S98user-start script
the My Cloud boots up in a clean manor. Not sure if I’m explaining this very well. Not sure why your version 3.04 would lock out SSH. Using the updaterc.d process changes the way the My Cloud boots. Using the user-start script just causes a few processes to stop.


I do understand what you are saying RAC. This is basically the start folder where once windows boots up in a clean manner, you get to run your own stuff which in this case scripts to stop services from running after they are started.

where once windows boots


Well yeah, Rac8006 is a window sort of guy… see how he uses the analogy of

and he is trying to describe the S98user-start script to me…

So I figure that by using a platform that he is familiar with, both he and I will form an understanding :stuck_out_tongue:

Hi rac8006,

I did put my commands in this file, but they are not executed on reboot. After reboot wdmcserverd and wdphotodbmergerd are still running… Any hints? Something else I should have done to have it executed?

/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/openvpn stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop

You need to use /etc/rc2.d along with the proper Sxx. The permissions in init.d are 755 in rc2.d they are 777.
This i what my user-start file looks like
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop