WD5000AZRX questions?

I have recently acquired a WD Caviar Green 500gb sata 3 to replace my old WD Cavia Blue 500gb sata 2 WD5000AAKS and I have a couple of questions:

  1. when running the Western Digital Data Lifeguard  Diag program the new HD is specified as being IDE whereas the old one is correctly specified as being Sata, is this normal or is there a problem? How can a Sata III drive be specified as an IDE drive?

  2. How come there is no difference in how the windows perfomance index indicated HD performance between the new HD and the old one? I assume there should be a much higher data transfer rate difference between a sata 3 and a sata 2 other than having 64mb cache compared to 16mb on the old HD.

I am using a Gigabyte 990XA-UD3 main board with an AMD FX-6200 CPU, 4gb ram and a sapphire 6670 graphics card. OS - Windows 7 ultimate 64bit.

thanks for any help at all


Hi well the green drives are recommended for a storage drive not as a boot drive but it should still read sata 3. What does device manager list the drive as is it a scsi device. Also Check your bios to make sure the sata controller is set to ahci mode. I would try a copy of HD tune pro and see under the info tab what it lists the drive connection speed at. 

Well windows device manager indicates as being an ATA device, whereas HD Tune Pro indicates it as SATA III which is correct and this is the test result:

HD Tune Pro in the info tab indicates 113MB/s as average speed.

Also if I set bios to ahci mode instead of native IDE mode, the pc locks up while windows is loading. Is this normal?

Hi you need to look under the info tab to see what sata speed the hard drive is using. If you installed windows under ide mode you cant just change it to ahci and have the system boot you have to enable ahci drivers in windows.

How exactly do I have to install the ahci drivers? I have tried updatedin directly from the control panel but that doesn’t seem to work. I also tried booting from the Gigabyte installation dvd (where I have found the 64bit win 7 ahci drivers) but it doesn’t read the dvd as bootable.



This is what the info tab says

Hi well MS has posted a auto fix for it hehe. http://support.microsoft.com/kb/922976   give that a try then reboot and change bios to ahci. Your info tab picture does not show. Just to let you know this is what that auto fix does.

  1. Exit all Windows-based programs.
       2. Click Start, type regedit in the Start Search box, and then press ENTER.
       3. If you receive the User Account Control dialog box, click Continue.
       4. Locate and then click one of the following registry subkeys:
       5. In the right pane, right-click Start in the Name column, and then click Modify.
       6. In the Value data box, type 0, and then click OK.
       7. On the File menu, click Exit to close Registry Editor.

Well I have actually formatted and followed windows boot as an ahci unit, loading the 64bit drivers during installation from the Gigabyte DVD.The bios now states it being booted as a ahci unit. However as you can see above the average speed has not changed. Also the western digital diag program still indicates it as being IDE and also the windows performance index still gives me the same number as when I was using the sata II drive. I have also done the changes to the registry keys you indicated above.

Any ideas?




ISTM that your speed is normal: