WD1003FBYX - DLGDIAG 5.20 : Error 0229: Missing Test Tracks


#1

Hi,

I just bought a brand new 1TB RE4 drive WD1003FBYX and when I tried to run diagnostic SW DLGDIAG ver 5.20 under DOS, running qeuick or extended test it didn't started but immediatelly displayed this error message:

Error 0229: Missing Test Tracks

I also ran another SW like HDTune and it reported SMART status OK. What does this error mean? Is there available some firmware update to fix it? It seems to me it's not a HW failure.


DataLifeguard error 0229
Is my WD Caviar Blue failing? (WDC WD5000AAKX-001CA0)
#2

http://support.wdc.com/techinfo/general/errorcodes.asp?lang=en#v10

Error is not listed sorry.

Were you able to use the drive? Copy a file and paste to the drive?


#3

I hoped that people from WD know their tools they created and it's diagnostic codes :frowning:

I don't understand the question...

I bought the drive in regular shop as end user in Czech Republic and I'm using it in my workstatioon PC.
 The error code was returned from DlgDiag 5.20 that I downloaded from WD site and run it under DOS.


#4

I just runt the DLGDIAG 5.20 on different drive at work with same firmware 01.01V02 and this drive doesnt display error 0229...


#5

Well, I received email with reccomendation to RMA the drive. I'll go to store tomorrow...


#6

I got a brand new WD1003FBYX drive as a temporal replacement from local store and it also suffers with error Error 0229: Missing Test Tracks. What does this mean? The serial number is not +1 but ~ + 67000, this is quite wide range of drives...


#7

Is the drive working properly even there is an error?


#8

Yes, it works well, yet... SMART status OK too.

But I'm confused that 2 same drives (with same FW) behaves different way. And nobody can give me explanation what's wrong.


#9

Except I cannot run selftest because the error appears immediatelly when i hit key to run quick of full test...


#10

Hard drives have a reserved System Area (SA) on the platters. The SA is also sometimes referred to as the negative cylinders. This area stores the bulk of the drive's firmware, SMART data, defect lists (G-list and P-list), plus manufacturing test logs.

I expect that there would also be test tracks reserved for read and write testing or calibration. Part of Data LifeGuard's diagnostic testing involves checking the read and write elements of each head. In order to test these components, I would think that the drive would need to write on a "scratch" area within the SA. Perhaps there was a manufacturing oversight that has rendered this area inaccessible???

Are there any differences on the labels of the "good" and "bad" drives, aside from the serial number?


#11

Sorry, I could not tull out the drive from running server now.


#12

I have the same error. I replaced the dlgdiag5.exe (5.04, see link) with the new dlgdiag5.exe (5.20) in my bootable CD, burn cd and start the diagnostic programms. When i hit R to start "Quickt Test" i get the error "Missing test tracks Error/Status code 0229 "

My HD: WDC WD20EARS-00MVWD0

Firmware: 51.0AB51

No problems with dlgdiag 5.20 and this HD: 

Model: WDC WD20EADS-00R6B0

Firmware: 01.00A01

http://support.wdc.com/download/dlg/Diag504fCD.zip


#13

Yes, I tried older version 5.04f and it works for me.

My story ended today that I got the same disk returned back - RMA was refused the replacement and they claimed the disk is OK. I have to belive it. Probably it's problem of dldiag 5.20  but it's still confusing that it has different behavior for 2 drives of exactly same type and FW version. In your case it's two different drives.


#14

This are the final words from WD email support:

We have passed this information to the development team in charge of your product. Please disregard the error message that you got since this was caused by the software and not an error from the hard drive itself.

So it seems don't worry about it more...