Is my WD Caviar Blue failing? (WDC WD5000AAKX-001CA0)

I own a WD5000AAKX which I use as system drive (WIN7 + UBUNTU). I saw lately some inconsistency (System Boot time from <1min up to >2min so I decided to check the disk.

Using HD Tune Pro I found an error (C7) pic1.jpg

I then looked around the forums and the internet and found that this error if stable is not necessarily a problem and can be attributed to other sources (cable etc). I tested with different cable, sata port on the motherboard and all seemed OK (no increase in the number 3274). I also tested the initial cable and sata port with the 500GB AAKS I have as back up to the AAKX disk of interest and both cable and sata port were NOT FAULTY (and still aren’t).

All this was about a week ago and in fact I almost forgot the whole thing, after testing (ALL TESTS) with the WD utility.


Yesterday I tried to backup my AAKX to the AAKS as usual using CloneZilla (as always). Even though the process completed and said OK at the end there were numerous I/O errors on AAKX and none on AAKS. So, I retested the AAKX disk on a different system (W7 32 BIT) and found the same ULTRA DMA CRC ERROR COUNT (which is normal since it is logged in the disk). Digging around I found another program GSmartControl and ran it only to find Prefails and the UDMA errors as shown

So considering a) the drive inconcistency, b) the I/O errors during the backup process and c) the results in the pictures can someone advise me on what to do?

A)  RMA the disk

B) Wait for the disk to die and then RMA

C) Continue using the disk like nothing happened

I repeat that the tests with the WD application (Data Lifeguard Diagnostics for WIN) are ALL normal.

I will be more than grateful for any answer/help/advise


can you install hard disk sentinel for monitoring ??

also change the hoster of the pictures… if it is the forum we need to wait a little longer to get the pictures until the moderators accept the picture

Thank you for your reply

I will try it ASAP and inform you of the results.

DavidSucesso wrote:

can you install hard disk sentinel for monitoring ??


also change the hoster of the pictures… if it is the forum we need to wait a little longer to get the pictures until the moderators accept the picture

Regarding the pictures I only used the picture button in the form. 

Is there a process for asking the moderator for permission to upload a picture? I mean I will probably need to upload the results from sentinel

Thank’s in advance

I also have a WDC WD5000AAKX-001CA0 that seems to be failing. I tested the drive with WD’s Data Lifeguard Diagnostic for Windows V1.24. It failed the first  test, then it passed the next two. I also tested the drive with WD’s Data Lifeguard Diagnostic for DOS and received the following message:

       Unable to Run The Test - Please Contact Technical Support

      Missing Test Track

      Error/Status Code: 0229

I tested the drive again with the windows version and it passed.

All the cabling is is good and I have tried different SATA ports. I have also tested other WD SATA 500GB & 320GB drives with DLG Diagnostic for Windows & DOS. The other drives passed all test .

Thanks in advance for any suggestions.

So I have just finished with Sentinel Diagnostics which only found the same problem with UDMA CRC CHECK

“Problems occurred between the communication of the disk and the host 3274 times.”

Apart from that everything seems in order (passed short, extended and conveyance tests while health status is 100%)

Now the question is what do I do with it?

Thank’s in advance


While looking around I saw your post which is probably unrelated to my problem

BUT googling around I found

a) This test code is unknown even to WD (see

b) This error at least in two instances wasn’t because of the disk but because of the SATA controller

c) WD offerred an RMA return at least for RayeR in the aforementioned post only 3 weeks ago

I am probably not the most experienced person to answer your question but why not call technical support, while running a few more tests using tools like HD Tune Pro, or Hard Disk Sentinel as suggested before?

Ok it’s official the situation is getting worse.

The ULTRA DMA CRC Error Count has increased!!! It is now 3286.

Any help is more than welcome (went 3287 as I was writing)


i have that kind of errors in my hard drives too… are they are all fine

what i recomend you to do is, test on another PC and with a known good sata cable or even a new one… if you have the possibility

You can try to replace the hard drive but you can do more harm than good… somestimes you get a lemon ( hard drive that fails quicly)

If the hard drive gave 0 read errors, 0 write errors and 0 bad sectors it seems fine…  i would recomend filling it up and read all again and check the smart data ( on another system)

David thanks for the reply. The problem is that I already tried different cable, sata port AND another PC as soon as I realized the problem. It feels that I am trapped in a condition waiting for the drive to officially fail. My problem is that I have a measurable drive inconsitency (yesterday it took me around 3 minutes to boot).

I am at a loss!!!

you do not need the drive to oficialy fail

you just need to report to western digital what has been happening the last times… if you dont feel confident using that drive you can rma it without saying smart failed but document it. i would talk to the support if i were you

“Pre-failure” refers to the type of attribute, it does not indicate that a particular attribute is about to fail.

The AAKS drive is a 3Gbps version whereas the AAKX is a 6Gbps model. Try limiting the SATA link speed to 3Gbps by installing the drive’s OPT1 jumper. Perhaps the higher link rate is error prone.

Thanks for the reply.

As of yesterday I put the disk at a SATA2 port with a SATA2 cable and I am waiting to see its performance. The error count yesterday remained steady. Of interest is that my 2GB internal WD20EZRX which is also SATA3 works PERFECTLY with the same SATA3 cable at the same SATA3 port.