DataLifeguard error 0229

I’ve been using the DOS version of Datalifeguard (1.24) to test my drives for any issues. It’s been a great utility until recently. It’s suddenly begun giving me “Error 0229: Missing test tracks”. I tried pulling a fresh .iso and re-creating the USB key (following the instructions from WD) I use for this purpose, and got the same error.

What’s causing this and how can I fix it? As of now, the tool is unusable.

The drives I’m testing are primarily RE4’s. Previously, these drives tested with no issues using the tool.

Hello, see if the link below below.

I did read that thread before posting.

That, sadly, isn’t helpful. There’s no work around or fix.

I’m testing Black label Enterprise drives that are reasonably current models. I’m attempting to verify if the drive is good or bad, or on the way to being bad (losing sectors or Read/Write errors), so the tool is fairly important to me. I’ve used this tool for quite some time and have never seen this issue till now. The Windows version works no problem, and until recently, so did this.

No, using the Windows version exclusively is not an option.

I’d prefer to use the manufacturers tool for this since it gives me a solid amount of SMART information for the drives condition, and, until now, was sure to work properly.

So, Western Digital, one of the major, and highly trusted drive manufacturers, drive diagnostic utility has a software flaw and there’s no fix or new version? For a year? Seriously?!?!?!