WD1002FAEX only being detected by controller as SATA II?


#1

System involved is a Dell Precision T3500,W3570 CPU, 12GB DDR3 PC3-10600 RAM, HD5850 video, OCZ 96GB SSD as OS & applications drive, Seagate Barracuda XT SATA III 2TB and Western Digital WD1002FAEX installed internally. All internal hard drives are controlled by a pair of ASUS U3S6 controllers. The DVD is controlled by the onboard SATA controller (x58 chipset) as is an external 2TB hard drive via the eSATA port provided by the MB.

ASUS Controller 1 is currently only controlling the OCZ Vertex.

ASUS Controller 2 is controller the Seagate Barracuda XT SATA III 2TB as drive 0 and the WD1002FAEX as drive 1

During POST the ASUS controller properly recognizes the Seagate as  SATA III, the WD is shown as SATA II.

The second controller properly recognizes the OCZ as SATA II.

Question is: Any ideas why the WD is not being seen by the controller as SATA III? No jumpers are in place on the WD as my understanding is that left unjumpered the drive should operate in its native mode of SATA III, 6Gb/sec.

Any help on straightening this out would be much appreciated.

Thanks,

Carl


Western Digital Black drive WD1002FAEX showing up at 3.0GB/S SATA 2.6
Sata 3 detected as SATA 2
#2

I am having the same problem with mine. Just got it yesterday. Asus P7P55D-E PRO mb with a Marvell SATA controller running the 6 Gb/s drives. The 1st drive is a Crucial 64 gig SSD and the WD 1002FAEX 1 TB drive is the second on the controller. No jumpers are on the drive.


#3

UPDATE:

Tried this same drive on a total of three different controllers in two different T3500 workstations with identical results. The controllers all see the Seagate Barracuda drives fine as SATA 3 and only see the WD drive as SATA 2.

This drive is out of lot 00Y9A0 - not sure if that should matter.


#4

I would definitely contact WD's Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#5

Managed to get a reply from Support. It appears that there were several batches of drives that were sold that had firmware improperly configured. This firmware problem seems to be very specific to the lots in question - mine happened to be 00Y9A0 which is one of 5 or 6 so effected.

WD has a batch file that repairs this problem. The provided solution willl not  run in a DOS shell so you you will need to be able to get to a 32-bit command prompt in order to apply. It also appears that the solution provided only looks to find the target HD as Drive C, and in my situation would not find the drive when connected to a SATA III controller. This is also a known "bug" in some cases with certain combinations of motherboards and controllers.


#6

Thanks for the useful disclosure of the remedy of such an annoying problem but where I can get the "WD's batch file" mentioned in this post.


#7

IT was sent to me via email by WD support. I would suggest if you have this issue that you start a support case and they eill confirm that your drive is among those affected.

These are the models the console application works with, per the text file that came with the file I received.:

    WD1002FAEX-00Y9A0
    WD7502AAEX-00Y9A0
    WD6402AAEX-00Y9A0
    WD5002AAEX-00Y9A0
    WD5002AAEX-32Y9A0

Hope that helps.


#8

Mine is WD1002FAEX-00Y9A0 which falls within the defective batch you mentioned and to save time in establishing a case with WD, I wonder if you would be kind enough to share with me or those unlucky fellows the patch file. 

My e-mail address is [Deleted]. 

Looking forward to your favourable reply!


#9

Hello,

I am in the same situation too : WD1002FAEX-00Y9A0 detected as serial ata 2 :confused:

I think first of a motherboard bios problem and i find this thread.

Could you share the patch with me too ? :wink: 

Here is my email adress : [Deleted]

Huge thanks :smiley:

Arnaud W.


#10

^^^

Yeah same HDD (WD1002FAEX-00Y9A) and being detected as SATA2

if someone would send the "batch file" that would be great :smiley:

[edited]

thanks


#11

same problem

still wating wd support reply

how long it takes ??????>>>


#12

PM me with your email. There is an easy fix available from WD Support if you are willing to be patient and wait for them to escalate it to an Engineer.


#13

my email is ....

please try with the new email


#14

Waw finally got the solution after fighting 3 hours !!!

I'm now in 6GB (SATA3) mode :smiley:

First, i would like to thanks CEGA_Maryland who send me the correct patch (support give me another one but it is not ok because it does an auto-detect and i need to force sata3 mode on sata2 port because sata3 is not supported by FreeDos).

The file provided does not work on Windows x64 (Seven...) so here is a little tutorial to correct the problem in several steps not depending of your OS :

So here's the steps i followed :

  1. First format you usb key in fat.

Create an usb boot drive with a tool like unetbootin.

Choose FreeDos which is a free MS-DOS version which contains sata drivers.

  1. Copy the file "WdSSpd.exe" on it.

  2. Shutdown computer

  3. Unplug sata3 cable and connect a standart sata cable.

Connect them to a sata2 controller on your motherboard.

  1. In the bios, you need to define your sata controller in "enhanced" or "AHCI" mode, not "IDE"

  2. Boot on the key, run "Live" mode.

My usb drive was B: so type "cd B:" to access it.

Run WdSSpd.exe and wait

  1. Allright, you will see a message which indicate to reboot.

  2. If you were in sata "IDE" mode, don't forget to reset it because windows will not boot.

That's it !! My marvel bios indicates that i'm in 6GBPS :smile:

Here is the file i used and provided by CEGA_Maryland (use this one as preference)

Here is  the new one given by WD Support

Arnaud W.


#15

this solution is applied also to windows ??


#16

This is a firmware console application that you will need to run by booting to a DOS prompt - not the DOS shell in Windows but to a basic DOS prompt off a floppy, bootable USB flash drive or similar.


#17

i just solved foolwing the instuctions and your file

thank you very much for your great help


#18

I have the same problem on the same drive. I followed you're instruction but when i run the file on the USB drive I get an error. Do you run the file with any switches?

Edit - Doh, I re-read and forgot to format my USB key in FAT. did that and it works perfectly. Thank you

Curious thing is, 2 weeks ago I opened an ticket with WD on this issue, they never mentioned any fix like this? Wonder why?

Again, a big thanks for posting this fix. Now running at 6GB's :smile:


Western Digital WD2000FYYZ only being detected by controller as SATA II
#19

I also have a similar problem with WD1002FAEX on Asus P6x58D-E motherboard. I read there is a way to perform firmware update though Windows 7 command prompt, but neither of the files above work for me. I have Windows 7 Pro x64, is there a different firmware?  Any help would be appreciated.


#20

I have the same problem using an MSI BigBang and the Marvell controller.  I really don't want to go through the a$$pain of reconfiguring and unpluging and replugging etc. though.  Plus, my TWO drive're running as a RAID, so I would hate to lose one through this config process.

Do you think WD will release an 'easier' fix?

Kurt