WD TV Live Streaming - Can't see Windows Shared

Hey guys,

I just got this little gem but I can’t get it to see my shared files. To be honest, when I go to Windows Shares, It does not even see my PC. So what I did, I spent 3 hours checking tutorials, but even my PC (WIN8.1) cannot see the WDTVLive as a device.

What am I doing wrong?

I’ve changed Workgroup to HOMEGROUP but no luck. 

I’ve did all the Netwrok tutorials out there and it should be set to ok. 

I got Norton Internet Security but I’ve added the name and IP of the WD to Full Trust.

Still I can’t see the device even if Sharing is on.

Help please?

First off WORKGROUP and HOMEGROUP are two different things and handle shares differently.  HOMEGROUP is Windows PC to Windows PC sharing system starting I believe with Vista on. WORKGROUP is a shareing for SMB (Server Message Block) protocol and is what non windows and windows use to communicate/transfer files.  Unless you have a compelling need for HOMEGROUP sharing suggest you disable it per some of the threads here and only use WORKGROUP sharing.  To help eliminate confusion recommend you change the name of your WORKGROUP to something besides the default “Workgroup”.  Remember to change it on all you PC(s) and devices (router, WDTV Live, etc.).  As far as seeing the WDTV from the Windows 8 machine in addition to having the same WORKGROUP name I think you need to have the SAMBA server enabled on the WDTV Live per page 31 of the manual.

The workgroup name for all devices in the network need to be the same.  For most instances,  the default name for a workgroup is WORKGROUP.  Be sure it is this way on your PC’s and the WDTV.  Turn OFF Homegroup in Windows; the WDTV doesn’t use the Windows 7 (and higher) Homegroup feature.  Using workgroups is a more standard way for networks.

It sounds like this is the first time you have tried to network any home devices, right?  If so, you need a crash course in Home Networking 101.

My computer in in WORKGROUP. 

The WD TV Live is in WORKGROUP.

I cannot see my computer via WD TV Live Windows Shares.

I tried everything and it seems to be hopless :frowning:


I reseted the settings, and then instead of connecting to my Wifi using the KEY, I used the WPS method. The moment it connected it detected my PC and all works flawlessly!


Congrats!  Glad it wasn’t “hopeless”.