Unable to access my Windows 7 PC through network shares

Hello all,

I am a long time user of the WDTV live devices.  I have both the older style WDTV Live with the smaller remote and the newer style WDTV Live.

Some background on my issue:

Older WDTV is directly wired into my network

New WDTV is wirelessly connected to my network.

Running Windows 7 Professional and have always had a user ID specifically for my WD’s.

Unfortunately around the time that I updated my newer WDTV Live to the latest firmware (1.12.14) I also began experimenting with the Homegroup feature in Win 7.  I created a home group and then tried to sync all of my devices with some success but then removed the homegroup.  Since I did this, the newer WDTV can not even see my PC on the network but my older WDTV has no troubles.  I have done a reset to the newer WDTV, tried the newer WDTV directly wired into the network, changed settings on my Windows 7 machine but still can not see the computer.  

I believe the issue is in my Windows 7 machine but can not identify where or why the older WDTV still works.   

ANY help would be appreciated.

Hi, Check if the new WDTV has the same workgroup name than the PC. Also follow the link below to review the steps to create a network share. 


1 Like

Thank you for that information, The WD only recognized computers in the default “workgroup”.  As soon as I changed my Windows 7 machine back to default, it worked right away.  

Interesting enough, I could not find how to change the workgroup for my WDTV live box.

Thanks again!

Grovered wrote:

Interesting enough, I could not find how to change the workgroup for my WDTV live box.

It’s in the network settings.

I have a WDTVLive SMP, a Win 7 Home Premium, and Win 8 Pro PC.  I do not require a User password for Windows on startup. I had problems with WDTVLive SMP seeing my Network Windows Shares. I usually had one  of the following: no PC or one PC in the Windows Share list; or the User and Password  was incorrect for the selected Windows Share. A reboot would fix the problem temporarily. I found that disabling the Local Group Security Option “Accounts: Limit local account use of blank passwords to console logon only”  was a more permenant solution.

Here’s the Windows 7 and 8 setup for a user with no password:

To run the Windows service under a user with no password you have to change the default security setting in Windows 8 Pro:

1.Open Local Security Policy under Control panel / Administrative tools
2.Select Security Settings / Local Policies / Security Options
3.Find policy Accounts: Limit local account use of blank passwords to console logon only
4.Change its value to Disabled

If you have a Home edition of Windows 7, the above settings will not be available. You will have to edit your registry instead

(using regedit.exe), although it is recommended for experienced users only. Find key


and change its value from 1 to 0.

Alternatively you can run the service under another user or the Local System account (it might cause problems with file

sharing and FFmpeg execution) or change your current user to have a password.