WD TV Live not detecting anything

I have had this WD TV Live for over a year now and have always been able to play video’s directly from my 1TB Harddisk.
But because we’re all modernising, I set-up a new NAS that I bought (a QNAP TS219P-II) today. I am able to access the NAS from anywhere on my network, except for the WD TV Live.

I have no clue or whatsoever to what the problem might be.
I have been messing around with the Network Settings all day, without luck.

After changing it to what I think is correct:

DNS: <IP given by ISP, copied from a PC on same network>

The WD TV finally gave me 3 “passes” on the network check, but after running the check again multiple times, it resulted in errors again (without changing any settings)

When the connection was still stable, I navigated to “Video > Network Shares” and the NAS appeared. It disappeared after 5 seconds.

When I now try to open Network Shares it doesn’t do anything; no error, nothing. Unless I remove the internet cable, then it says it can’t connect.

I don’t know why I can’t access anything on the NAS from the WD TV. After these changes and firmware upgrade (from 1.01.00 to 1.06.15) the WD TV won’t even read USB connected harddrives anymore.


  • QNAP is accessible from other computers
  • I run a Microsoft network
  • Workgroup is WORKGROUP (also on WD TV)
  • Setup: Modem > Router (Linksys E2500) > Linksys 8 Port Switch > All computers and WD TV and NAS

I have no idea what the issue is and what I am doing wrong.
Does anyone know where I can start with looking?

Help is very much appreciated.

I’ve always set my DNS to the same IP as the gateway, meaning the router gets the DNS from the ISP automatically and all PCs request name resolution info via the router.

I have tried all three DNS Server IPs that I can see in CMD/ipconfig, resulting in the same thing.

I don’t think the network configuration is wrong. I think for some reason my WD TV just won’t detect anything on the network.

Because when I am connected, and I go to Video > Network Shares, it doesn’t do anything. No error, just nothing.

But when I change the configuration to something that is wrong or won’t work, it’ll say that it can’t connect when I try to access Network Shares.

Does anyone know a solution to this?

Is this a Western Digital problem? Is this a QNAP problem? What can I do to stream  movies from my NAS to my WD?

Are these just general networking problems?

Also, my workgroup is the same on my WD as on my NAS/Computers.

Does anyone know something I can do?
I still haven’t figured out how to let the device detect other devices on the network.
Though I am pretty sure that the problem lies in the WD product, as all my other network devices CAN detect other devices on the network.

Did you try upgrading the firmware with the latest release?


At that time I did update the firmware, but I see a new one has been released now.

I’ll try installing that and then I’ll post an update about the status of the WD product.