WD TV live: issues with Windows/SMB server

Hi all,

this is my first post … I bought my frst WD player this year, so please forgive if I missed something already discussed here, or draw false conclusions because I am not totally familiar with the box yet.

Generally the box works fine most of the time, but now I am seeking help/inputs to get it 100% stable. Right now I get around 1 malfunktion per week, which seriously dismals what marketing people call “user experience” nowadays. Wireshark captures are available. The issues do randomly appear and go away after PC and WD box reboots. The Workstation sharing the media is WIndows 7 pro, the box is a WD TV live with latest firmware, connection via 100MBit ethenet cable.

Issue #1 The WD box fails to recognize the master browser, as well as the workgroup browser. The Wireshark packet trace shows the WD local broadcast for __msbrowse__ and workbroup<1B>, I see the machine holding the browser role (which is not the same machine as the one holding the media share) respond by sending a directed packet to the WD, and I see the WD send another browser query, over and over, endlessly…

Conclusion #1: the WD box browsing code has two faults: sometimes it does not pick up browser query responses, and it does not implement a timeout when searching for a browser. These two issues lead to an endless loop when trying to find Windows shares.

And off topic, having almost two decades of experience with the dreaded Windows Browser and having seen Microsofts pointless attempts to fix it. At some point I lost confidence they ever get it right. I strongly recommend that WD does not entirely rely on the Windows browser, but does also implement a setup screen where one may enter \server\share directly.

Issue #2: when tracing failures, sometimes I see the Windows PC responcd with “out of server memory” SMB error packets when the WD tries to login to access the share. Now the message is clearly an idication of a windows server service fault, there is plenty of memory and any other space I can think of available at the PC side, and the WD is the only active session, but nevertheless this WIndows problem sets off a series of quite unpleasant automatisms on the WD box:

(when the WD tried to connect)

  • the box displays misleading username rejects / password faults in an endless loop

(when the box attempts to access the media share)

  • the box claims that I removed the share

  • the box removes the share from the Media Library

Its especially the last decision which I think is a poor one, since it does permanent damage to the box configuration. Less experienced users in my household like Grandma and the Kids are able to reboot the equipment to fix things, but after this issue arises they would have to re-browse the Windows network, re-attach the share and wait for the Media Library to rebuild (which, btw, takes some time when you have 400+ videos stored on the share) - this is way beyound their knowledge and patience.

Conclusion #2: OK, there is an unresolved issue in my Windows PC setup, but it triggers a very clumsy series af poor descisions in the WD box, leading to permanent removal of the media share from the Media Library. I wish I could somehow freeze the WD setup once done and tested properly, so network related failures do not inflict such great damage.

And just to mention it: before I sunk an Ethernet cable into the livin room wall, I tried to operate the box on WLAN. Though I have ecellent WLAN conditions in my living room (~4m distance to Access Pont, free air) with dozens of WLAN devices, mostly PCs and Smartphones, having operated flawlessly I noted that the WD crashes are fare more frequent when operating via the WLAN. Now I have around 1 crash per week, operating on WLAN its more like 1 crash per day, but this is a different story, and I am - for other reasons - happy to have the cable anyway.

Any comments helping me to resolve the SMB issues are welcome


wow, there’s a lot in that post

I’ll probably come back to it in the morning

but my first impression

you’ve done a fare amount of digging

you admin the problem is not just he box by windows browse function

you admin you dont think microsoft will ever get it right

so my conclusion

my not skip all this smb server stuff

and go NFS

either from a linux machine or you can use FreeNFS or Hanewin as NFS server from windows

you’ll find all these smb problems just go away

NFS is much more stable

and throughput is much better as well

Hi KAD79

the NFS way out is already on my list al plan B. Indeed I already set up a free NFS server on the Windows PC to see if that gives me a quick solution. Unfortunately I was also stopped right at the beginning of my attempts by issues, so I put it aside for the moment:

  • the WD box does not provide any GUI to mount a NFS share. All I got is mount WIndows Shares, and Mount MAC shares. Now I do know that the MAC is running Unix at its core, but I also suspect that I need to set up some browser-like search facility … just setting up the NFS server did not make anything show up on my WD, so I gave up early.

  • on the server side I have a whopping 10TB of storage space in one single partition, and I was not quite sure whether NFS can handle shares this large. Most do max out at 2 or 4TB.  I suspected that this might be the reason for NFS not working right away, but did not sink any time into it yet,

Another reason is, that especially my kids have their own laptops and do sometimes  play vide material directly from the share as well, and I don’t want to roll out NFS clients on all machines if I don’t have to.

Nevertheless some tutorial on how to set up the WD with NFS on Windows would be greatly welcome, and I’d give it a try if I don’t get going SMB pretty soon.

Thanks so far


I think the “Out of Server Memory” thing is fixed by adjusting the IRPStackSize registry value.


for NFS

if you go to network settings and scroll down

there will be an option “Linux Shares” by default it is “Off”

turn it on then when you go back to video and select source there will be an option for “Linux Shares” which is NFS

I know sort of a funny way to do it, considering that the WD’s core is linux



I have implenented the change and will observe whether it has any effect. Since I was never able to reproduce the problem I cannot do anything else than wait and see wether it happens again.

Thanks very much …


I have the same issue going on to samba solaris server I switched to nfs so far so good but only a few days in. My master browser is my samba server I see they same issue WD live streaming  C3H can’t find master browser reset it works. I also have the password issue so it’s obviously a bug WD needs to fix. 

Btw my wd live and wd live plus doesn’t have this issue. When it’s connection is lost it fails with network folder can’t be found then you go back refresh and it works fine.