WD Sync one-way only?

Hi!

Is WD Sync one-way only? Meaning content gets uploaded from source to My Cloud but not the other way?

When I add a file to my local storage (synced with MyCloud), it will get uploaded to My Cloud.
When I add a file to My Cloud, it does NOT get synced (downloaded) to the local synced folder.

Is this the correct behavior or am I missing something?

Have you looked at the current User Manual information (Chapter Four) on WD Sync?

catow
USA

Wow,the new manual was launched without any announcement…

I’d suggest using a proper backup tool that will sync or mirror files wherever you want, not where it wants you to put them.

Try FreeFileSync.

Yes, but how does it answer my question?

I don’t use WD Sync but I would say you missed something if you read the User Manual about WD Sync.

The way I read it you have to have WD sync on all the devices you want it to work on and there is a specific folder that the files have to go in. See excerpts from User Manual below.

After installing the WD Sync software, to sync a file or folder on your computer, use your computer’s file management utility to copy and paste or drag and drop it into the WD Sync folder. The WD Sync software automatically copies it first to the WD Sync folder on your My Cloud device and then to any other computers connected to it. After that, the WD Sync software automatically updates any changes to the file, at any location, on the other configured devices.

Copying Into the My Cloud Folder When you copy a file or folder into the My Cloud folder on your computer, the WD Sync software automatically copies it to the WD Sync folder on:  Your My Cloud device Any other computer in your network with the WD Sync software installed. Then, whenever you change or delete a file in the WD Sync folder on any device, the WD Sync software replicates the change on all of the other devices.

WARNING! The WD Sync software is designed for data files. It is neither intended nor suitable for syncing your applications or executable program files

I suggest you go back and read over the information in the User Manual again.

cat0w
USA

1 Like

My issue is, it works for me only one-way. Please read my question again. The way it works for me is not real sync. Sync mean I can add a file to either local or cloud folder and the change will replicate to the other synced locations.

For me, it only works when I add a file to local folder - then it does get synced onto MyCloud. If I, however, add a file to MyCloud, it does NOT get synced to the local folder. That’s not sync. That’s just uploading.

1 Like

I’m wading in. Mine ain’t syncing in any direction. :frowning:
Trying to tackle the problem with WD support’s assistance. At least this time I’m getting a menu so I can configure it!

If I understand the original poster’s dilemma they are talking about copying files independent of the Sync program to the WD My Cloud Share which is designated as the WD Sync repository on their My Cloud. Their issue is the Sync program doesn’t copy that new file from the WD My Cloud Share TO their computer’s WD Sync folder.

What they are saying is the syncing of files (for example new files) with the WD Sync program is only one way: Computer new file -> WD My Cloud
And not two way: Computer new file -> WD My Cloud and WD My Cloud new file -> Computer

For the OP it may be better to use third party sync programs. While I have not tried it others use FreeFileSync to synchronize files between their computer(s) and the My Cloud. I do not know off hand if FreeFIle Sync supports syncing from the My Cloud to the local computer but assume it does.

I understand what the OP asked and I say the answer to his question is provided in the User Manual. It tells what WD sync will do and how to use it.

If it will not do what he wants done then as you suggested use an alternative.

cat0w
USA

The User Manual is not quite clear on exactly how the copy process works other than updating files across all computers using WD Sync (and using the same User/Login on the My Cloud). This is what the WD My Cloud User Manual states: “The WD Sync software automatically copies it first to the WD Sync folder on your My Cloud device and then to any other computers connected to it. After that, the WD Sync software automatically updates any changes to the file, at any location, on the other configured devices.

That doesn’t exactly address or answer the OP’s question. However, having just setup the WD Sync software on my PC it DOES INFACT sync the contents added to the My Cloud Share folder containing the Sync folder to the local computer’s hard drive WD Sync folder. The copying is by directional for me. What I did as a test was to copy files from a separate folder on the computer using Windows File Explorer and copy files from another folder on the My Cloud, into the Sync folder on the My Cloud, those files were then synced to the local computer’s Sync folder via the WD Sync program.

For the OP and others who are having trouble with the WD Sync program, uninstall the program. Then reinstall it. Others have indicated that fixes certain WD Sync issues for some reason. Or just use the FreeFileSync or other third party sync programs.

I tried uninstalling and reinstalling the WD Sync app. Sync is still unidirectional only (local -> cloud). Gonna file a bug report with WD.

EDIT: I see I have failed to state that I’m running OSX (10.10.5), not Windows.

Hi there, I habe the exact same problem as stooovie, files ar getting synced only from computer -> NAS and not in the other direction. Have you managed to solve the problem? I’m running my wd sync on Windows 7 and already reinstalled it twice. It is also very time consuming because it indexes all the files again when reinstalled although they are already on MyCloud. It took almost one day for 1Tb. So I’m not looking forward to reinstall it again…

Try this:

  1. Remove the configuration in the WD Sync client on each computer
  2. Delete the .WDSyncHistory in the root of your share
  3. Rebuild the content database within the admin console.
  4. Add the device back in via the WD Sync client.

I also noticed this scenario. If device “A” uploaded 100 documents and device “B” is syncing. Do not update a document on device “A” until device “B” has completed it’s sync. Otherwise there will be confusion and they will not sync properly.

The logs are stored in this folder (Windows)
C:\ProgramData\Western Digital\Logs\WD Sync[userName}

@stooovie it is a bug.

@Myron I’d like to know if WD Support has a real solution vs sending out a RMA unit. I received a Mirror Gen 2 after they could not figure out my sync problem. I’ll be sending back the My Cloud 4TB after I complete my isolated testing, then transfer my data. I’ve quick restored my Mirror twice since I received it on Monday.

@Bennor I like the idea of using FreeFileSync, but when you’re outside your LAN is that product useful?

@cat0w a bit harsh. If you search thru the forums you’ll notice there is a fair number of owners who are having problems. It is a bug in the product. I see this happen between development teams at my 9-5. Lack of coordination, lack of skilled resources, shrinking budgets, pressure from upper management to deliver ahead of schedule with scope creep, and marketing not in sync with reality. They are being disrupted by companies that can give their core product real attention with laser focus.

I’d like to be a fly on the wall during WD development team meetings. How to get yourself out of a quagmire 101 and get your mojo back.

for the record. I bought another passport ultra during the holidays while $70 off and when I had a open support ticket. WD makes great drives, but their software skills are lacking. I’ve been a loyal consumer of their products for years. I’ve only purchased 1 non-WD external drive in the past 10 years.

2015 purchases
1 WD MyCloud 4TB
2 WD MyBook 4TB
1 WD Passport Ultra 3TB

<2015
1 WD Passport Ultra 2TB
1 WD Passport 250GB
1 WD MyBook 2TB (died)

Yes it is useful. The program can connect through SFTP to do a sync (and use the SSH login for username/password). The user would of course have to enable FTP via the My Cloud Dashboard and configure their router/gateway to pass the FTP port (typically 21) through the firewall to the My Cloud. See this link: FreeFileSync Synchronize with SFTP

Alternatively if one is rolling their own VPN tunnel to their local network they can sync through the VPN tunnel.

A bit more on SFTP on the My Cloud and changing the SFTP login information at this link:

https://community.wd.com/t/sftp-setup/95350

Post edited and updated

1 Like

I have been having this issue with a new WD My Cloud Mirror, and I think I have found the cause of this bug and a work-around solution.

The symptoms I was experiencing was that files would sync from the desktop to the NAS, but not the other way around (NAS to the desktop). However more specifically, it was only file adds and deletes that would not sync from NAS to desktop; file modifications would sync correctly.

The NAS seems to get into this state following an improper shutdown (e.g. pulled the power plug), which triggers a file-system check on reboot. After the file system check, this one-way sync issue occurs.

The solution is to reboot the NAS via the web admin control panel (on My Cloud Mirror: Settings -> Device Maintenance -> Reboot). After a normal reboot, two-way syncing seems to work again.

1 Like

I had the exact same syncing issue on my WD MyCloud. If I add a file on one computer, it would copy/upload to the My Cloud, but it would not copy/download the file to the other computer.

I am on Windows 10. I opened up the file explorer, clicked on Network -> WDMYCLOUD -> . Then it prompted me to enter my username and password. After I did this, the WD Sync application immediately started downloading all of the information that was on my MyCloud but not in my local “My Cloud” folder. In a short while, both directories matched again!

Hopefully this helps you guys :slight_smile:

The post by pking does help to solve the problem. You need to reboot at the web admin control panel (Setting> Utilities> Device maintenance > press “reboot” (make sure all back up and sync has stopped before proceed rebooting) and after reboot you may need to do step 2 at the web admin control panel :

Step 2 : Setting > General > Cloud Access > configure > press “rebuilt”

After reboot and “rebuilt” for the connection between your device and the router, it shall be working. Hope this helps. Cheers.

1 Like

A post was split to a new topic: Removed post

i have the same issue only syncs in one direction even fter uninstall install and reuilt…

i cannot beleve that this happent to a lot of people with WD