WD Red 3TB showing capacity as 2TB

I recently purchased 2 new WD red 3TB drives for NAS .However one disk is showing the full 3TB capacity but the other is showing only 2TB .Tried the disks in a Window7 pc with same result ( initilised with GPT).Any ideas anyone? wd lifeguard also only shows 2TB capacity.

Hi there,

When you installed the drive on the computer, did you formatted the drive as MBR? If yes, try formatting the drive as GPT as MBR only recognizes up to 2.13TB capacity.

See if the following link helps


Hi Ermorel

Thanks for reply.The first thing I tried was formating with GPT.This drive is behaving exactly as if it were a 2TB drive.

I have tried the drive in 2 different pc and a nas with same result ,whereas a second 3Tb i purchased at the same time is ok.I have been in contact with WD support and at this stage it looks as If will be returning the drive.I have never in over 20 years of computer experience seen this happen but theres a first time for everything.It looks like a 2Tb got into the production line of 3TB drives!!!

very odd that one works and the other doesn’t.  I assume if you have an intel chipset, you have the latest RST package installed to help Win 7 see the GPT drives correctly??

Could this be your problem?

GigaByte BIOS bug results in loss of 1TB capacity:

Hi Fzabkar

You hit the nail on the head!!!. It was a gigabyte motherboard that caused the problem.fixed it with hdat2 Phew

Theres a pint (or two) of Guinness waiting for u if u ever get to Ireland :slight_smile:

Thanks again

Pat O’Neill