WD Passport Detected in Mac and Windows, but suddenly recently its only detecting in Mac

Hi, I have my passport external HD. Previously i only have a Windows and my HD has been working well for me. then i got a Mac and use the HD for both Windows and Mac and its working fine (I’ve installed the needed software to read the HD as needed). Suddenly, today, when I tried running the HD on my window, it detected the password, but after i logged in, it didn’t detect the HD. I thought there was something wrong with the HD, but then when i plugged it to my Mac, it’s running just fine. Appreciate some help and advice to make it readable on my Windows again. Thanks so much!

Open the disk management on the Windows side, and check if it is recognized there. 


Thanks so much for the advice,

however, i’ve tried that and it doesnt work. 

when i plug in my HD into my PC, the normal password prompt for the WD pops up, and then there’s an indication of drive existing. However, when i click on it, it says “disc is corrupted or unreadable”. i’ve even tried this on a friend’s laptop and it indicates the same thing. 

but then, when i plugged it into my Mac, it works just fine. the weirdest thing is, before this i didnt face this problem at all. transferring data from one OS to another was a breeze. Suddenly this happened and im totally weirded out. 

appreciate it so much if anyone can help. 

thanks again

What format type are you using for the passport? NTFS, HFS+, FAT32? If you are using HFS+, it will not work fine on Windows computers.