WD My passport ultra poratble 3GB


My 3TB WD hard drive is now showing only 1.99TB after fomat. I tried to fix with disk management but failed.

In disk management , i can see 2048 GB NTFS as active and 746.49 GB as unallocate. I am not able to extend the Active partition since the extend volume option is greyed out. There is no option to merge the partitions.

I tried to merge the partitions using external software, but got failed.

How can i fix this?

Please help to fix this issue.


You most probably formatted/partitioned it MBR instead of GPT

MBR (Master Boot Record) supports a maximum size of 2TB … GPT (GUID Partition Table) supports Up to and Over 2TB capacity size.

Reformat it NTFS and select GPT Partition Format.

Hi everybody,

I have a WD Green 3tb in a docking station USB.
The disk is in a GPT Table.
My problem is that i can see only 2048GB and I don’t have any other partition (like unallocated space)
I lost 746gb!
In diskpart i have a disk of 2048gb.
I tried differets software like EaseUS, Minitool Partition, Gparted in linux, but every software see 2048gb.

How can I repair it?