WD My Passport Ultra 2TB on Mac Yosemite 10.10.2

Hi, I just bought a new WD My Passport Ultra 2TB today. Right out of the box, I plugged onto my MBP 15" Retina with Yosemite 10.10.2, nothing pops up. Disk Utility doesn’t show any mounted new drives.

I unplugged it, plugged into my friends PC laptop, it worked. So I formatted away NTFS into exFAT.

Unplugged from PC and plugged back into my Mac Yosemite. Drive doesnt show up, but it showed up on my DISK UTILITY app. I followed the instructions from WD SUPPORT.

During formating/partitioning of my HDD, an error pops up and says " Partition failed with the error: Couldn’t unmount disk."

How do I get this HDD to work on my Macbook Pro?

All firmwares, drivers, updates are the latest and up to date.

I bought this 2TB HDD to use as data backup. Now I can’t even use it. Please help.


Ok nevermind.

I managed to solve this problem on my own. LOL :laughing:

I thought the drive can’t be unmount, this would be generally be associated with drivers and/or applications utilizing it.

So here’s I resolve the issue.

I reboot my Mac Yosemite 10.10.2 into recovery mode (Hold CMD+R when powering up). That’s where use the Disk Utility as usual. This time round, partition was successful. Restart my OS and my new HDD is working.

Happy man now! =D

I hope this will help someone with the same issue as me.


1 Like

Welcome to the Community, and thank you very much for sharing the outcome and a new solution.

I have been having a problem with my 1tb WD usb drive it is not showing up, tried this but still the problem hasn’t been resolved. Wondering if one of the tech people or admin can help, I’ve a lot of data I need to gain access to.