MyPassport suddenly no longer mounts on MacBook Pro

My 2GB WD MyPassport was last successfully connected to my Macbook (still running **10.9.5) **about two months ago (I use it almost exclusively for Time Machine backups).

I tried using it recently but the main partition no longer mounts.  A small exfat parition mounts, but I can’t seem to fully verify that parition from disk utlities. 

Here’s how it looks via Terminal:

   0: FDisk_partition_scheme *2.0 TB disk1
   1: Windows_NTFS ExFatPaws 200.5 GB disk1s1
   2: Apple_HFS Paws 1.8 TB disk1s2
cherbourg-2:~ xxxxx$ diskutil verifyVolume /Volumes/ExFatPaws/
Started file system verification on disk1s1 ExFatPaws
Error: -69673: Live file system repair is not supported
cherbourg-2:~ xxxxx$ diskutil mount /dev/disk1s1
Volume ExFatPaws on /dev/disk1s1 mounted
cherbourg-2:~ xxxxx$ diskutil mount /dev/disk1s2
Volume on disk1s2 timed out waiting to mount

Is this similar to the other mount troubles that people are having or are my troubles likely just due to the drive dying and/or being corrupted?   I never had troubles with the drive in the past.  I updated to 10.9.x months and months ago and did several successfully TM backups to the drive since that initial upgrade.  

It’s a portable drive and thus no ac adapter.  WD Support, please don’t just tell me to try a different cable or port.  In other threads people tell you those solutions don’t work and then you disappear.  

(I will admit I haven’t tried it on another mac yet.  I will eventually try that but I’m not usually around other macs currently.)


I recommend you try some basic troubleshooting:

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the computer, not through a hub).

3- If possible try another USB cable Or another computer.

4- Go to "Disk Utility” to verify if the drive shows up there.

If the drive shows up in disk utility but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

Same exact problem. What a coincidence that we’re all having the same problem and it’s all our fault because we’re pulling out cables. Seems to be working fine on Windows too.

I know it’s been a long time since I originally posted my problem, but I wanted to provide an update. (All the recent WD Store xmas spam emails have reminded me to do an update.)

I was certain that I was going to have to re-format my drive because of the reasons listed above. (I couldn’t even fully verify the drive with Disk Utility, etc.)

However, thanks to TechTool Pro I was able to get the drive working again. It’s been awhile so I forget exactly what it may have found and/or fixed, but the short version is that it got things back to normal. And ever since then the drive has been working okay (although I only use it infrequently, for monthly backups, etc.).

So, in summary, don’t give up all hope when the built in Disk Utility can’t fix an issue. Perhaps try some software that has some additional tools in its box.