WD My Passport keeps ejecting from MAC!

Please help! I can’t get any work done since my WD My Passport 4 TB drive keeps randomly ejecting from my 2018 MacBook Pro, running Mojave 10.14.3. I have tried different ports, tried switching the cable, kept using Disk Utility with First Aid to make it at least run for a couple of minutes, but then it just pops up the notification “Disk not ejected properly” and it unmounts itself. Any experience with this?

2 Likes

Hi spacemouse,

Did you check My Passport on another Mac for the same issue?

I’m having same issue with 2TB My Passport for Mac.

Also tried with the supplied USB-A cable (instead of USB-C) and same result.

Tried on a different Mac (running High Sierra), and tried reformatting the drive. Same results.

1 Like

I have the same problem. Nobody has an idea how to solve this?

I am having the same problem. I even bought a new WD Passport drive thinking it was the drive. Same problem! Help please???

I’m pretty sure it’s the cable, not the drive. I used one of the Usb-c cables with multiple ports (usb, sd card, etc.) with it and it kept disconnecting. Switched to a single usb-c to usb cable, plugged in the drive and it hasn’t disconnected since. I’m guessing it’s a power issue in the cable that doesn’t provide an even amount of power to that one port all of the time making the drive disconnect.

No problems whatsoever when using the drive on a PC.

I’m also having this issue. Other My Passports are working fine. My Passport 4TB doesn’t show up anywhere. I plug it into my iMac and drive has a solid white light. Vibating to the touch but that is about it.

Hi, Same happened with my WD Essential 8TB drive. It kept ejecting.
I also have a new 6TB WD Essential with a new cord and power adapter. Same thing, ejects by itself on my iMac. I have turned off energy saver “put hard disc to sleep” under both tabs “battery” and “Power adapter” in energy saver window. I will let you know if it fixes it.
How many backup devices are people suppose to own?
Irritated!

I have the same issue, I have a 2TB my passport ultra and I’m working with MacBook pro-2018, and it’s getting eject every time I’m transferring files. I have no idea what should I do.

How did you solve the problem? I have the same, very frustrating. Thanks for your help.

hi . yes, I solved my problem by buying a new wire connection. the problem was the connection line which was too long.

I have a mac that has USB type-C but my original wire was a usb3 so I had to connect the hard through an adapter. and that was the problem.

I just bought a new wire which connects my hard to my mac straight without any extra connection and the problem is fixed .