Mac keeps ejecting My Passport for Mac

Hi, I’ve attached My Passport for Mac to Time Machine but it keeps ejecting it. WD support says this happens when running 10.12 or under and to upgrade but I’m running High Sierra 10.13.6
Any ideas?

Hi sadiechretman,

You can try using the different USB port of Mac Computer or try using different USB cable to resolve the issue. It is also recommended to avoid using USB hub and connect the drive directly with USB port of the computer.

Hi Brandon,

Thank you very much for getting back to me. I’ve tried both USB ports on the MAC. I don’t use a USB hub so I have been connecting directly. I’ve tried the passport and cable on another Mac and it works so I know the cable works. Any other thoughts?

Cheers, Sadie

Hello sadiechrestman,

Did you contact WD Support in this concern for resolution?

Hello. No I haven’t contacted support. I will do so now.
Thank you

I had this same problem. I had my passport plugged into a mac external hub and kept ejecting every few minutes. Alls I had to do was buy a Micro-B to Usb C cable off Amazon and now the problem is completely gone.

To resolve the hard drive auto-eject issue, tweak the power management settings of Mac, as shown here:

  1. Go to Finder > Applications > Utilities > Terminal.
  2. On Terminal, type “pmset –g | grep disksleep” and hit Return.
  3. Check the value of disksleep. If it is low, provide a significant number.
  4. Type “sudo pmset –a disksleep #” (here, replace # with a suitable number) and hit Return.
  5. Provide the admin password when prompted.
  6. Check the changed sleep value using the “pmset –g | grep disksleep” command.

The above solution will fix the drive auto-eject problem. After that, use the hard drive to save and access data as usual.