WD My Passport - cannot see list of files to retrieve with WD Backup

#1

Hello,

I’ve just bought and installed a 2TB My Passport which is running with Windows 7 on my PC. I set up a regular back-up plan using the WD Backup software for all of my program files and my personal data. This appears to be running properly. I see the correct time and size of the last back-up on the WD Backup window. However, when I click on “Select Files to Restore” in the Restore option, no list of files appears at all.

I can see that a folder called David has been created in the folder WD Backup.swstor in the My Passport root location but the “date modified” does not change when I run back up. How can I see and restore the files have been backed up, if any?

Regards

David

Any suggestions would be appreciated.

#2

Hi David,

When you look for files to restore, does a rotating circle appear near the top. The folder stucture appears when the circle stops. It does take a long time for the Folders to appear and you should then be able to find the files for any previous backup listed on the right side.

The wd Backup.swstor is a very complex structure. I have been able to find files there, but it is not obvious and I’m not sure how you select the backup version. My feeling now is Keep Out!

Cliff

#3

Hi Cliff,

Thanks for your reply. No there is no rotating circle, simply a window called “Restore Files” which remains blank however long I wait. I have just tried running another back-up, having been away for ten days, and although the Last Back-up record shows the time it ran and quotes a sensible back-up size (227.5GB) the WD Backup.swstor/David folder date modified has not changed, nor has its size which still shows as 4KB (yes KB!). I can only assume that, if the back-ups really are being created, they are being saved somewhere else.

I think my best step next is to uninstall the software from my PC and try reinstalling it.

Regards

David

#4

Hi Cliff,

I’ve just uninstalled the WD Backup.exe program and reinstalled it but the outcome is still the same. The back up is reported as successful but there are no files listed when I look for files to restore. My next step is to contact WD Support and, if that fails, to return the disc drive as faulty.

Regards

David

#5

I have the same problem. The backup is in the drive, I can see the volume encrypted. But I cant restore. Did you find any solution???

#6

Hello Clifford,

I am new to this forum so I am not sure if I am following the right protocol. I am having a similar problem as David where I am able to plug in my External Hard drive, I can hear the disk spin for a few seconds and it shuts off and tries to start again as the activation light on the external drive keeps flashing with beeps. The beeps stop after some time. I have tried different USB and USB cords, tried it on another computer with no luck of seeing or retrieving any backed up data. I took the external drive to Micro Center yesterday and they suggested that there could be some hardware damage within the external drive. The prices they were quoting for alternative data recovery were quite exorbitant.

At this stage I do not know if you can suggest any place where my data could be recovered at reasonable cost. Before pursuing this, I also wanted to see if I could purchase a same drive and swap the external components, assuming that the storage disks on my old drive are still good, and try to retrieve the data. The drive I have is WD 1TB Silver My Passport For PC External Hard Drive - USB 3.0 - WDBBEP0010BSL - 01. Any advise or guidance you can provide will be greatly appreciated.

Cheers! Jerry

#7

Hi Jerry,

Your problem is a different one to mine and, unfortunately, sounds expensive and probably terminal. The symptoms sound very much like what happened to my old external drive which was not a WD product. Almost certainly there has been a failure to the internal read head that picks up data from the drive and it is physically touching the surface of the drive. The worst thing that you can do under these circumstances, as I discovered to my cost, is to keep trying to read the data as this simply makes the damage worse. I paid a specialist recovery firm here in the UK their standard charge of £205 to dismantle the disc and try to recover the data, but without success. Here is their diagnosis: “Initial problem on the hard disk was read/write head failure, although this did not cause any media damage to start with, it seems the hard drive was powered on for a period of time after the read/write head failure which caused media damage on the disk platters.” They could only restore 8% of the data which was not enough to be useable. In the end I lost all of the data that I had backed up and had to resort to recovering what I could from my current PC and two previous PCs that, fortunately, I had kept and not thrown away.

The initial problem with my new WD My Passport was eventually resolved when I tried for a third time to restore the drive to its original factory settings and reinstalled it. It now works fine although the back-up process seems quite slow considering that the size of the most recentl back-up is just 35GB. I’ve resorted to using the Back up and restore function within Control Panel on my Windows 7 operating system which is both more intuitive and faster.

Good luck and remember, it may be better to use the Cloud to back up in future.

Regards David

#8

I am also in a mess, can"t assess my data in my 4t passport. It will ask me for the password and then stop

#9

Thank you David!

#10

I have the same problem with a 4TB drive. The backup claims to have worked but the restore shows nothing. There is a folder called “WD Backup.swstor” but I dont have access to it. I also get occasional popups showing that the recycle bin on the drive is corrupt.
I tried to copy files manually but I dont have permission to create folders.