WD My Passport 4TB won't work on USB 3.0 port, but does work on USB 2.0 port

Hi,

I bought 2 x WD 4TB My Passport drives (WDBYFT0040BBK-0A) about 3 years ago. They were working fine for a long time but lately they’ve been acting up.

They’d keep disconnecting and reconnecting when plugged in. Now they won’t show up at all. Sometimes if I keep disconnecting and re-connecting them they’ll work, but then they might stop again soon after.

Then I switched the cable to the USB 2.0 port and they work fine (although slower, obviously). Swapped back to the USB 3.0 and still not working.

I’ve tried many cables and 3 different PCs, same story - only work on USB 2.0 ports.

I have two WD Elements portable hard drives also. Both work fine in USB 3.0 ports. This proves the problem isn’t the cables or the ports.

I tried uninstalling the drives in Device Manager, restarting the PC and reconnecting. Didn’t work.

I’ve seen this problem reported on several forums, but never found a solution.

Does anyone have a solution?

Thanks!

Hi,

I would like to inform you that the drive is compatible with the interface:
USB 3.0
USB 2.0

I would suggest you to try with a different USB cable and test the drive health status through WD Drive Utilities.

Title: How to install WD Drive Utilities( For both Windows and MAC)
Link: [How to install WD Security & WD Drive Utilities]

Hi Neha_07,

Thanks for your reply.

I tried a different USB cable (several, in fact) but all had the same results.

I ran the drives through the WD Drive Utilities tests. All passed. Screenshot attached.

I know you said the drive is compatible with USB 3.0, but it doesn’t appear to be. For either of my My Passport drives.

What else can I try? What’s the next step?

Thanks,
Dneville

Hi Neha_07,

I’m still waiting on a reply.

What’s the next thing I should try?
This seems like a known issue.

Thanks!

Hi Neha_07,

I’m still waiting on a reply.

What’s the next thing I should try?

Thanks!

Hi Neha_07,

What’s the next thing I should try?
This seems to be a known issue.

Thanks

Does anyone have a solution to this?

Thanks!