My Passport Drive Utilities works with USB2 but not USB3

The WD Drive Utilities works when My Passport Ultra is plugged into a USB 2 port, but not when in a USB3 port. I can read and write OK under USB3, but when I run Drive Utilities under USB3 from the Windows 7 Start menu it just gives the message “Attach a supported WD disc.” This happens if the disc is already attached or if I attach it after the message appears. The utilities seem to work OK under USB2, so I am hoping that they still apply when I go back to using USB3. Still, this is definitely seems like a bug.

My USB3 is a 4 port Anker USB 3.0 PCI-E Card in an HP p7-1280t computer, the USB2 ports are the built in computer ports.


Try to check if the unit is on the latest drivers to, perhaps it could be driver related. Have you tried other USB 3.0 drives?

According to Device Manager the drivers are up to date. I have a Hitachi 3.5" HD SATA in a “plugable” USB3 interface. Of course it is not a WD disc, but the response is the same. I haven’t tried it on USB2 yet, but I will.