Wd my cloud unbrick virgin image


#4

but, i saw on an other topic that i need a wd my cloud RED. Because, i have one.


#5

4TB Image:


WD MyCloud 4TB problems (bricked)
#6

it will be working with the RED wd my cloud? Thank for the image.


#7

What is a red WD My Cloud? This image will work with the regulary (Gen. 1) 4TB My Cloud 1-bay-NAS running firmware 04.xx.xx. http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf


#8

the type of hard drive. i verified that my own was a red. I airweady tried with a normal image and it’s not working: i see there in this topic: [GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

[…]
“Now today i got another new WD cloud drive, same capacity of 3TB. I didnt care for warranty. I made sure this drive was on the same EXACT firmware. For whatever reasons that i dont want to get into, i decided that i will open up the new drive and restore the raid partitions from other drive’s image hence bringing over all my mods and suff… However the new drive is NOT booting. Its stuck at the white led.”


#9

After unbrick my wd make the same thing. it stay in this cycle: restart and the led is white.


#10

All My Cloud devices uses WD Red hard drives as far as I know.


#11

I’m going to try with your img.


#12

The type of hard drive (WD Red, WD Green, etc.) is immaterial. Some of us have “unbricked” spare SATA hard drives from other manufacturers in the My Cloud enclosure. I’ve unbricked a 250GB and then a 1T hard drive (both from other manufacturers) in the My Cloud enclosure using the following directions that were posted elsewhere in this subforum.

How to unbrick, replace or restore original WD My Cloud single hard drive firmware:

These basic directions assume you have a 4GB or larger USB flash/pen drive, a computer with SATA connectors or some form of external SATA enclosure/docking station, basic knowledge of how to boot PC using a boot disc, basic knowledge of how to use Linux.

Note: Use and proceed at your own risk!!!

• Download original_v3.04.01-230.tar.gz to a flash drive: https://drive.google.com/file/d/0B_6OlQ_H0PxVQ2l5MTNvQk1xSUU
• Used Ubuntu Live/Boot CD: http://www.ubuntu.com/download/desktop
• To avoid damaging non WD My Cloud hard drives remove or disconnect them from the computer.
• Backup any data on your My Cloud as these directions may result in the erasure of all data on hard drive.  
• Insert USB Flash/Pen drive containing the file original_v3.04.01-230.tar.gz (or it's extracted contents) into PC before booting with Linux Live/Boot CD
• All terminal commands run from Root user or Sudo. For purposes of this guide Sudo was used.
• After booting with Live/Boot CD open terminal window by typing: 
[ctrl] + [alt] + [t]
Then type:
sudo apt-get update 
sudo apt-get install mdadm parted

To install new/used hard drive start with step 1. 
To repair existing bricked WD My Cloud hard drive start with step 13.

Note: Starting from step 1 will erase hard drive contents. If hard drive contains important data, backup hard drive before proceeding.

1. Find the My Cloud hard drive name (sda, sdb, sdd, sdc, sde, etc.) by typing:
sudo fdisk -l 
or 
sudo parted -l

Note: For these basic directions "sdb" is used. 

2. If you get GTP errors running fdisk or parted then try the following command:
sudo gdisk /dev/sdb

Then type "o" then type "w" to fix GTP errors.

3. Run parted utility:
sudo parted /dev/sdb

4. Type "print" to see what partitions exist on hard drive.

5. If any partitions exist, remove each of them by typing "rm 1" (where 1 - number of partition)

6. Create new table:
mklabel gpt
mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M -1M
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
set 1 raid on
set 2 raid on

Type "quit" to exit parted.

7. Format data partition:
sudo mkfs -t ext4 /dev/sdb4

8. Reboot computer, boot back to Linux Live CD. From command line run: 
sudo apt-get update 
sudo apt-get install mdadm parted.

9. Run sudo fdisk -l or sudo parted -l and note the drive names just incase the /dev/sd* location changed.

10. Create main RAID partition, type: 
sudo mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2

11. Wait for RAID creation to complete, type:
sudo watch cat /proc/mdstat 

Wait to 100%. Then type:
[ctrl] + [c] for close.

12. Stop auto-loaded raid, type: 
sudo mdadm --stop /dev/md0

If /dev/md0 not found type the following to find RAID mount point: 
sudo ls /dev 
or
sudo grep md

13. Start normal raid (must be /dev/md0), type: 
sudo mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2

14. Using terminal window navigate to USB Flash/Pen drive location. Example: /media/ubuntu/<drive name> If the contents of file original_v3.04.01-230.tar.gz have not been previously extracted on the USB Flash/Pen drive, type:
sudo tar xvfz original_v3.04.01-230.tar.gz

15. Upload backup images to WD's hdd:
sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/md0

16. A Note: If for what ever reason the My Cloud fails to boot (white LED), or problems with upgrade to newer firmware failing/not working (ex. UI fails to load) try the following alternative step.
sudo mdadm --stop /dev/md0

sudo dd if=kernel.img of=/dev/sdb5
sudo dd if=kernel.img of=/dev/sdb6
sudo dd if=config.img of=/dev/sdb7
sudo dd if=config.img of=/dev/sdb8
sudo dd if=rootfs.img of=/dev/sdb1
sudo dd if=rootfs.img of=/dev/sdb2

17. Shutdown PC from terminal window by typing: shutdown -p -H 0 Or use "Logout" from menu.

18. Disconnect hard drive from computer/external connector and connect to WD My Cloud circuit board. Then connect power to the My Cloud circuit board to turn on WD My Cloud. Boot process may take 5-10 min or longer. LED light should change from White to Blue.

Note: If the WD My Cloud fails to boot with either a solid white or red LED, then reattach hard drive to PC/docking station, reinsert USB Flash/Pen drive, boot back into Linux, go back to step 13, then proceed to step 16 to push the three "img" files to their respective partitions, shut down PC and try booting the hard drive again with the WD My Cloud circuit board. 
If the drive still fails to boot (white or red LED), the GTP entry probably needs to be repaired. If that is the case try step 2 above to rebuilt the GPT entry (will probably erase drive contents) and then perform the rest of the subsequent steps. If step 2 doesn't work then start from scratch at step 1. Backup any files if needed from sdb4 (the mountable ext4 partition containing the shares) prior to starting from step 1.

19. After WD My Cloud boots to Blue LED, access the Dashboard with web browser (http://wdmycloud/). Proceed through initial access screen then enable SSH on the Settings -> Network -> Network Services section. Often the capacity will be incorrectly listed, fix by selecting Quick Restore (or Quick Factory Restore) from the Settings -> Utilities section. The device will reboot and rebuild the system files.

20. After factory restore has been performed and WD My Cloud boots, restore any settings (like Static IP) as needed and update the firmware if needed. Be patient. If there was existing data on the hard drive it may take the WD My Cloud OS a long time to scan/catalog the files.

#13

i successfully unbricked my wd my cloud 4tb!. Thank you.:grinning:


#14

I had problem with step 10 and it have repercussion on other steps using md0 “device or resource busy”.
I saw in this file:

  • sudo cat /proc/mdstat. sdb1 and sdb2 were using by md127 or something and caused the problem. I make
  • sudo mdadm --stop /dev/md127 for stop it, after everything worked.

#15

That’s what will happen if the Linux OS mounts the raid partitions (sdb1 and sdb2). In my case the raid partitions didn’t get mounted so I didn’t include that step from the previous directions that most of those steps came from. Note: the previous directions have been updated a bit from when I used them last year to create the procedure I used to unbrick several drives.


#16

HI, could someone post an image for 3TB disk. All links are dead, tried the 250gb but it doesnt work for me.

Thank you very much


#17

Here you go:
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVNTN6c2F4SXEwQVU

The owner changed the file name from original_v3.04.01-230.tar.gz to original_v03.04.01-230.tar.gz and messed up all the links. xD


#18

Thank you. There is a big problem with links, almost everthing was dead so u helped me. I realized, that i made a few mistakes in linux in command line. The new disk is working, the blue shines & rises:)
The easies way could by one image of the whole disk, but i am not sure how big it could be. The things with linux are pretty hard for newbies and me, it took me lot of time:/

THX


#20

Hi, nogood.
Please i need help.
I own a 4tb mycloud with firm. 4.4. like this one.
I erase everithing from the disk.
Now i need the image of the disk.
Can you please guide me to the prosses? i am new in this.
I am dowl. the image but what is the "dd if=/mnt…instrtuctions? and were can i found them?
Please Help

Thanks in advanse.


#21

Have a look at the post (and the mentioned link) above:


#22

Hi nogood,
I am using win 10 …i dont have ubudu…
Is thear a way to copy the image in the 4tb disk? Can i use a prog.?
I dont know what is “dd if=/mnt…” instruction…is that ubudu?
If i am going to use a program like Acronis will i have the same results?
thanks


#23

Why did you “erase” everything from the disk? What “unbrick” methods are you trying to use?

Have you tried using Fox_Exe’s method for unbricking a first gen single bay v4.x My Cloud hard drive?

https://drive.google.com/file/d/0B_6OlQ_H0PxVbzZac0plbkZKeGM/view


#24

Maybe the best way: buy a proper NAS were you can change the harddsik (e.g. Synology or qnap), put the hd out of the My Cloud and put it into the new NAS.