WD My Cloud Unable to access device. (500) error! Worked great then just stopped! FW V1.03.41

Hi all, new on here so be gentle.

Android GS4 running Kit Kat. using the My Cloud app.

Got this new “device” an 8tb My Cloud Mirror and  the pictures uploaded worked great  from the public shared pictures folder for a while then decided to keep coming up with the below error.

WD My Cloud Unable to access device. (500)

Its shows the picture eventually on the screen but this notice keeps coming up just before the picture and stays there until I click the Ok tab. It also wont allow me to scroll to the next picture in that folder, this used to work too.

In the music folder its used to play (Stream) ok, then again just stopped but I cant get the music to play at all when this is happening.

A reboot solves the issue for a very short time but it keeps coming back after only looking for a few pictures.

I can see the device ok  using the MyCloud app so thats not problem, its the above problem that is bugging me.

What makes me think its a problem with the WD software is I can use the ASUS Aicloud app as thats what the device is connected  too an ASUS router, thus I gain access to the  files on the device through that with no issues whatsoever. Infact its playing music ok right now as I type this.

I can also see the photos ok through the Windows desktop ok too so its not a problem with the unit but the software.

Its connected to the router via a network cable.

I have reloaded the firmware in case it was corrupted but this made no difference.

I am going to reset the unit via the dashboard on the PC but I am not sure its that which is causing the problem.

Any suggestions?


Oh great now it wont even reboot after a system restore.

Why did I buy this rubbish!

Right it’s back up but still has the same problem as I first said about.

However this also happens with another Android device so it’s not the unit.

Any suggestions?

Does the problem happen while doing remote access, local access, or both? You can try some of the suggestion on the following link.