WD General Network Error 500, iPhone App, HELP!

I have tried every potential solution I could find in this forum and nothing works.  

  1. Reinstall app
  2. Try on another device
  3. Restart drive
  4. Update firmware
  5. Rebuild library
  6. Forward ports
  7. Completely shutdown firewall/security

I can access files through the “All” tab but nothing else.  The WD Photos app doesn’t work either.  I open the app, select my device and get the message “No photos found.”  I’m pretty savy when it comes to tech but I have not been able to solve this problem since I bought the drive.

There are a lot of threads about this but no viable solutions.  







Hello Murdox, welcome to the WD Community. Are you able to do remote access from the My Cloud desktop app or the wd2go.com website?

Installing and using the WD My Cloud Desktop App

How to remotely access a WD My Cloud Personal Cloud drive 

Thanks for the response. Yes. I can access the drive through the desktop app.

Well this was useless

Hi again, sorry for the delay. Have you tried doing a System only restore? If that doesn’t work you can try a full factory restore, but note that this one will delete all of your files. If the problem continues after this I would recommend to contact support directly, they can help you narrow down the cause of the problem. 


check your photo folder name. If it contains apostrophe ', then it will get this error. Just delete the apostrophe from the folder name and all will be good.

hello have to update the time of the WD team is a possible solution

My advice is rip the drive out and throw it in the bin. It is a pile of trash and is in my opinion the most unreliable stressful piece of ■■■■ I have ever bought.

Check your network settings of the router for the Cloud connectivity.
Check if required ports are enabled or shortly enalbe all of the cloud device network settings incl Internet accees. Then check access by the APP of your phone. Then let your router learn the used protocol and save it. Disable again internet access at the router (if not required). Check again you app on the phone…it should still work.
I experienced similar issue. some weeks ago I disabled internet access of my cloud server, connected by an extra network hub to my internet /wlan router. just learning of network flow helped to fix network protocll issue caused by limited rules defined at the router for the cloud device.
cheers, Thomas