WD My Cloud Mirror Gen 2 Bricked in a Weird Way


I have a brand new My Cloud Mirror Gen 2 8TB NAS. I’ve just let it overnight copying some files and when got back to it next morning the NAS was in stand by mode and didn’t get back online anyway. I left it for a while, when a power outtage happened. Since then, the NAS keeps booting forever. The power LED keeps blinking blue for hours. I’ve tried the 40s reset, but all 3 LED kept the same way they was, 2 solid blue for the drives and blinking blue for the power.

The weirdest thing is that even if I remove both drivers and power on the unit, the drive LED are both solid blue.

The unit is unable to get a IP from the router, but if I connect straight to my computer it will give an 169. IP range and I can ping it. Or I can set a fixed IP, like and ping it also. So, I can communicate with the unit from my PC somehow.

Using a USB stick connected to the unit to boot with WD Recovery didn’t work. Every time that I power up the unit the drives LED are instantly solid blue and the power is yellow for a second than changes to blinking blue.

The fact that the unit lits drives LED even without a drive installed makes me think that this is not something related to the drives, but some flash ROM or something that the unit might have.

I would really appreciate any help!

Thanks in advance!

If you can not access the unit’s Dashboard in order to initiate a factory reset, then it could indeed be a controller/enclosure failure. If so, then the best approach would be to replace the unit under warranty.

There are advanced SSH instructions available in order to initiate the process, but it requires for SSH to be enabled first.


But since I live abroad I guess that is not an option…

Do you think UART soldering and all process described in several topics deserves a try?

I had a similar problem. I spoke to about 6 people before I got the right answer. Apparently there are about a dozen (not 2) ways to reset the beast. I eventually got to someone who told me how to reset the NAS yet another way and everything worked fine after that. Go figure!

And how did you reset it?

lol perfect example of what not to do on a support forum