WD My Book for Mac 2TB and OS X Yosemite

Hi All,

After installing Yosemite I noticed that I can no longer access My Book for Mac. I didnt give it much thought as it is still doing the hourly updates but when I go into Time Machine and try to pull up a date it doesnt move.

I contacted WD yesterday and they say it is a issue with Apples Time Machine. I then contacted Apple Care and explained what was going on and they said WD needs to issue a patch. I do recall having a similar issue when Mac went to Mavericks.

Does anyone on here have an idea of what is actually going on?

Thanks in advance for any assistance. :slight_smile:



Take a look at this thread:


1 Like

Thanks for the link. So from what I gather so far no solution. But will keep an eye on that thread for any updates or will WD send some sort of notification out? Same thing happned when Apple issues Maverick.

It would be really NICE if we could get some sort of update saying someone has seen this and at least is aware this is going on… Maybe just a message telling us to go screw ourselves, the issue is not being resolved… Something. I’ve been checking this forum for over two weeks now after originally becoming aware of this problem. Apple support forums point us to this site and this site points us to Apple. Come on.

I have had a similar issue. I recently had a WD 3TB hard Drive replaced - TWICE because the first failed after two weeks and the second didn’t work at all! This was the model with both FireWire and USB. I received a replacement Drive which is the newer 3TB USB model. Unfortunately, it has compatability issues with Yosemite 10.10.1. I cannot set up the Drive Settings,  or use/find Backup or Retrieve in the WD Smartware. Smartware does not seem to recognise this Drive on Yosemite. I am awaiting a response from Western Digital who have thus far been very helpful on a personal one to one basis. Hopefully it can be resolved soon!

Smartware is incompatible with the new update of Yosemite. I hope WD updates the Smartware so we can access our drives again. Also, using NFS, I was able to use my WD drives to watch videos on my TV. With the new update of Yosemite, I can’t anymore.


My WD My Book live, was working fine until i installed the Pre-relase OX X Yosemite Update Beta this morning once it had installed, I was  very kindly told me that my WD was no longer compatable and I need a WD sofwtate update :frowning:

I can still see the drives and enter the setting etc but unable to use the time machine fucnation to carry out the backups 


The big white charging elephant is that this is something that APPLE has done.  Until Yosemite ALL my WD Passport drives and Seagate Drives (whether solo powered or external powered) darned well worked.

Now, WD - one of the largest providers of hard drives in the UK (if not the world) cannot seem to get drives recognised.

It is laughable - seriously.  Are Apple now looking to sell portable hard drives??? No, so why won’t they read?

Yosemite has been out a couple of months now - and how long was the beta program??

WD and Apple get your acts together.

Some help to you - USB hubs sometimes allow you to get tyour drives read - however not all hubs are the same.

Good luck my fellow sufferers - I can sing the misery song too - Yosemite wiped my data - thank you Apple.

I had the same problems after buying a macbook pro from a windows machine.

cured the problem by fixing the ip adrees of the WD Drive and turning off my fire wall and back on again.

All works fine with My Book Live and My Cloud drives on the same network after doing this.

whatever happened with your device and Yosemite?   I just bought a My Book Studio, but am afraid if I upgrade to Yosemite on my MacBook Pro, it will no longer work.

Everything was running great until I installed Yosemite 10.10.2. Now my Time Machine has stopped working and my Mac can no longer see MyCloud on my home wifi.

I note from previous posts that this is something you’re aware of - and, hopefully, working towards a solution. Are you able to provide an indication as to when normal service will be resumed?



I see the original message is marked as “solved”. May we know how this issue was solved?

Thank you,


1 Like

The WD Smartware backup software does not work for Yosemite.  One of their tech people confirmed this for me today,  No plans to upgrade software,  Don’t but this drive if you need to use their software.