WD Link issue with WD TV Live media player

Hi, I use WD Link and it detects My Book’s, WDTV LIve media player and WDTV Hub. However when I create a desktop shortcut for the WDTVLive media player and the WDTV Hub, I cannot access the device. When I create a desktop shortcut for the My Book, I can access the folders on it. Message I keep getting is cannot connect to device’s IP.
I can ping the WDTVLive media player, but cannot access it or map the drive. I cannot Winscp or FTP to the device either.
This has worked previously, but a little while ago I upgraded from Windows 7 to windows 10.
Please help.

The WD TV products rely on SMBv1 protocol, which Windows 10 no longer supports.

There’s lots of articles online that describe how to restore SMBv1 client compatibility to Win10.

Yeah…that sort of worked. I can now use the desktop shortcut to access the device’s IP from WD Link. But it says the device is empty. I know there are movies on the WDTV Live. Any idea why I can’t read the content of the WDTV Live device? I appreciate your help.

You have a usb device plugged into the WDTV, I’m assuming?

No…I do not have a USB device connected.

Then what are you connecting to? The WD TV has nothing to map to.

Sorry…I thought I said that I have the WD TV Live device that I have a network connection to. I apologize for that. I map a network drive using the WD Link application. However, once I can now map the drive, it says that there are no files on the device.

That’s what I’m trying to say. If you have a WD TV Live, there are no files on there that you can access via a Mapped drive unless you plug a USB device to it (like a flash drive or portable hard drive).

The WD TV Live Hub, on the other hand, has an internal hard drive where you can put files, but not the WD TV Live.